"인증서 인증 구성 업데이트 필요" 오류와 함께 업그레이드가 실패합니다.

문제

VMware Identity Manager 3.3.2로 업그레이드하려고 할 때 다음과 같은 오류 메시지가 나타나고 업그레이드가 중단됩니다.

업그레이드 전에 테넌트 <tenantName>에 대해 인증서 인증 구성을 업데이트해야 합니다. 업데이트 전 검사가 실패했습니다. 업그레이드가 중단됩니다.

원인

이 문제는 CertificateAuthAdapter에 대한 인증서가 버전 3.0 이전에 마지막으로 추가되거나 업데이트된 경우에 발생합니다.

해결책

  1. VMware Identity Manager 콘솔에 로그인합니다.
  2. ID 및 액세스 관리 > 설정으로 이동합니다.
  3. 커넥터 페이지에서 작업자 열의 링크를 클릭합니다.
  4. 인증 어댑터 탭을 클릭한 다음 CertificateAuthAdapter를 클릭합니다.
  5. 업로드된 CA 인증서 섹션에서 인증서를 제거하려면 빨간색 X를 클릭합니다.
  6. 저장을 클릭합니다.
  7. 루트 및 중간 CA 인증서 섹션에서 파일 선택을 클릭하여 인증서를 다시 추가합니다.
  8. 저장을 클릭합니다.
  9. 가상 장치 콘솔로 돌아가서 업그레이드 명령을 다시 실행합니다.