VMware Identity Manager 3.3.1, 3.3.2 또는 3.3.3에서 버전 3.3.4로 업그레이드하는 경우 업그레이드할 특정 버전으로 3.3.4를 지정해야 합니다.

사전 요구 사항

프로시저

  1. 루트 사용자로 VMware Identity Manager 가상 장치에 로그인합니다.
  2. 다음 updatemgr.hzn 명령을 실행합니다.
    /usr/local/horizon/update/updatemgr.hzn updateinstaller
  3. 업그레이드 버전을 3.3.4로 설정하려면 업그레이드할 VMware Identity Manager 버전에 따라 올바른 명령 버전을 실행합니다.
    /usr/local/horizon/update/configureupdate.hzn manifest --set-version 3.3.1.0

    또는

    /usr/local/horizon/update/configureupdate.hzn manifest --set-version 3.3.2.0

    또는

    /usr/local/horizon/update/configureupdate.hzn manifest --set-version 3.3.3.0

  4. 업데이트 URL을 3.3.4 URL로 변경하려면 다음 명령을 실행합니다.
    /usr/local/horizon/update/configureupdate.hzn provider --url https://vapp-updates.vmware.com/vai-catalog/valm/vmw/5C08B358-F782-11E1-8F08-78776188709B/3.3.4.0
  5. 장치를 업데이트하려면 updatemgr.hzn 스크립트를 실행합니다.
    /usr/local/horizon/update/updatemgr.hzn update
    3.3.1 또는 3.3.2에서 업그레이드하는 경우 이 스크립트를 사용하려면 dualbootupdate 파일의 위치를 매개 변수로 제공해야 합니다. --file 옵션을 사용하여 명령에 파일 위치를 제공하거나, 옵션을 사용하지 않고 명려을 실행하고 요청이 있을 때 정보를 제공합니다.
    참고: 업그레이드 프로세스에서는 운영 체제를 SLES에서 Photon으로 마이그레이션할 때 dualbootupdate.tar.gz 파일을 사용합니다. VMware Identity Manager 3.3.3에서는 이미 Photon을 사용하지만 3.3.1 및 3.3.2는 그렇지 않습니다. 따라서 3.3.1 또는 3.3.2에서 업그레이드할 dualbootupdate 파일의 위치만 매개 변수로 포함하면 됩니다.
    --file --file 옵션을 사용하여 Photon 운영 체제 및 해당 패키지를 포함하는 dualbootupdate 파일의 위치를 제공합니다. 기본 위치는 /dualbootupdate.tar.gz입니다.

    업그레이드 중에 발생하는 메시지는 /opt/vmware/var/log/update.logupdate.log 파일에 저장됩니다.

  6. 가상 장치를 다시 시작합니다.
    reboot
  7. 업그레이드된 장치의 버전이 3.3.4인지 확인합니다.
    vamicli version --appliance
    새 버전이 표시됩니다.

결과

업그레이드가 완료됩니다.