VMware Identity Manager 가상 장치를 오프라인으로 업그레이드하려면 먼저 다음과 같은 사전 요구 사항 작업을 수행해야 합니다.

  • 업데이트하기 전에 가상 장치의 전체 상태를 캡처하려면 가상 장치의 스냅샷을 생성합니다.

    스냅샷을 가져오는 방법에 대한 자세한 정보는 "vSphere 가상 시스템 관리" 설명서를 참조하십시오.

  • Microsoft SQL 데이터베이스에서 db_owner 역할을 취소한 경우, "Linux용 VMware Identity Manager 설치 및 구성" 가이드 3.3 버전에 설명된 대로 업그레이드를 수행하기 전에 다시 추가해야 합니다. 그렇지 않으면 업그레이드가 실패합니다.
    1. sysadmin 권한이 있는 사용자 계정으로 Microsoft SQL Server Management Studio 세션에 로그인합니다.
    2. VMware Identity Manager에 대한 데이터베이스 인스턴스에 연결합니다.
    3. 다음 명령을 입력합니다.

      Windows 인증 모드를 사용하는 경우 다음 명령을 사용합니다.

      USE <saasdb>;
      ALTER ROLE db_owner ADD MEMBER <domain\username>; GO 
      						  

      <saasdb>를 데이터베이스 이름으로 바꾸고 <domain\username>을 관련 도메인 및 사용자 이름으로 바꿔야 합니다.

      SQL Server 인증 모드를 사용하는 경우 다음 명령을 사용합니다.
      USE <saasdb>;
      ALTER ROLE db_owner ADD MEMBER <loginusername>; GO 
      						  

      <saasdb>를 데이터베이스 이름으로 바꾸고 <loginusername>을 관련 사용자 이름으로 바꿔야 합니다.

  • 해당 스냅샷을 작성합니다.
    • 배포에서 각 VMware Identity Manager 장치의 스냅샷을 생성합니다.
    • 외부 Microsoft SQL 데이터베이스를 사용하는 경우에는 외부 데이터베이스의 스냅샷 또는 백업을 가져옵니다.
  • SSL 인증서 요구 사항이 충족되었는지 확인합니다.

    VMware vRealize Automation 8.3에서 VMware Identity Manager를 사용하는 경우 vRealize Automation 8.3에서 Tenant-In-Host 이름 다중 테넌시를 사용하도록 설정의 지침에 따라 SSL 인증서를 구성합니다.

  • updateoffline.hzn 스크립트를 사용하여 업그레이드하며 배포에 프록시 서버가 포함되어 있는 경우 프록시 서버를 사용하지 않도록 설정합니다.

    프록시 서버를 사용하지 않도록 설정하는 방법은 기본 운영 체제에 따라 다릅니다. VMware Identity Manager 3.3.1 및 3.3.2에서는 SLES(SUSE Linux Enterprise Server) 운영 체제를 사용하며 여기에는 YaST 유틸리티가 포함되어 있습니다. VMware Identity Manager 3.3.3은 Photon 유틸리티를 포함하지 않는 YaST 운영 체제를 사용합니다.

    3.3.1 또는 3.3.2에서 업그레이드하는 경우 다음과 같이 YaST 유틸리티를 사용합니다.
    명령줄에서 프록시 서버를 사용하지 않도록 설정합니다.
    1. 다음 명령을 실행합니다.
      yast2

      YaST2 제어 센터 대화상자가 열립니다.

    2. 네트워크 서비스를 선택합니다.
    3. 프록시를 선택합니다.

      [프록시 구성] 대화상자가 열립니다.

    4. 프록시 사용이 선택되어 있으면 선택을 취소합니다.
    5. YaST2 유틸리티를 종료합니다.

      업그레이드를 완료한 후 프록시 서버를 다시 사용하도록 설정합니다.

    3.3.3에서 업그레이드하는 경우 다음 단계를 수행합니다.
    관리 콘솔에서 프록시 서버를 사용하지 않도록 설정합니다.
    1. VMware Identity Manager 콘솔에 로그인하고 장치 설정 > VA 구성 페이지로 이동합니다.
    2. 구성 관리를 클릭한 후 관리자 암호로 로그인하고 프록시 구성을 클릭합니다.
    3. 프록시를 사용하지 않도록 설정합니다.
    4. 저장을 클릭합니다.
  • 가상 장치에서 10GB 이상의 사용 가능한 디스크 공간(/dev/sda)을 사용할 수 있는지 확인합니다.
  • 오프라인 업그레이드에 대한 디렉토리 공간 요구 사항을 충족해야 합니다.
    표 1. 3.3.1 또는 3.3.2에서 3.3.4로 업그레이드하기 위한 디렉토리 공간 요구 사항
    디렉토리 최소 사용 가능 공간
    / 2 GB
    /var 3GB
    참고: dualbootupdate.tar.gz 파일을 /var 디렉토리에 다운로드하는 경우 최소 7GB의 사용 가능한 공간이 필요합니다.
    dualbootupdate.tar.gz 파일(해당되는 경우)을 다운로드하는 디렉토리 7 GB

    vRealize Suite Lifecycle Manager를 사용하여 오프라인 업그레이드를 수행하려면 dualbootupdate.tar.gz 파일을 다운로드해야 합니다.

    표 2. 3.3.3에서 3.3.4로 업그레이드하기 위한 디렉토리 공간 요구 사항
    디렉토리 최소 사용 가능 공간
    / 4GB
  • VMware Identity Manager 3.3.1 또는 3.3.2에서 직접 업그레이드하는 경우 my.vmware.comVMware Identity Manager 3.3.4 제품 다운로드 페이지에서 VMware Identity Manager Service Virtual Appliance Dual Boot Update를 다운로드하고 VMware Identity Manager 가상 장치의 디렉토리에 해당 파일을 저장합니다.

    VMware Identity Manager 3.3.3은 SLES(SUSE Linux Enterprise Server) 운영 체제에서 VMware Photon™ 운영 체제로 전환되었습니다. 따라서 VMware Identity Manager 3.3.3에서는 이미 Photon을 사용하지만 3.3.1 및 3.3.2는 그렇지 않습니다. VMware Identity Manager Service Virtual Appliance Dual Boot Update 다운로드에는 dualbootupdate.tar.gz 파일이 포함되어 있으며 여기에는 Photon 운영 체제 및 해당 패키지가 포함되어 있습니다. 업그레이드 프로세스에서는 운영 체제를 SLES에서 Photon으로 마이그레이션할 때 dualbootupdate.tar.gz 파일을 사용합니다.