이전 버전의 Broker 및 Desktop Agent는 Horizon 어댑터와 통신할 수 없습니다.

문제

vRealize Operations for Horizon 6.1 또는 이전 버전의 Broker 및 Desktop Agent는 기본적으로 Horizon 어댑터와 통신할 수 없습니다.

원인

vRealize Operations for Horizon 6.2.1 및 이후 버전에서는 TLS 1.2가 적용되지만 이전 버전에서는 TLS 1.0이 사용됩니다. 에이전트를 최신 버전으로 업그레이드할 수 없는 경우에는 어댑터에서 TLS를 사용하지 않도록 설정할 수 있습니다.

해결책

  1. vRealize Operations Manager 수집기 노드에서 /usr/lib/vmware-vcops/user/plugins/inbound/V4V_adapter3/work/msgserver.properties 파일을 엽니다.
  2. 다음 명령을 추가합니다.
    enforcesslprotocols=false
  3. Horizon 어댑터를 다시 시작합니다.
  4. Broker Agent가 설치되어 있는 Horizon Connection Server 호스트에서 Broker Agent를 어댑터와 다시 쌍으로 구성합니다.