ESXi 버전 4.x 스크립트로 작성된 설치에 익숙한 경우 스크립트로 작성된 ESXi 설치 또는 업그레이드를 수행하기 전에 ESXi 4.x와 ESXi 5.x에서 스크립트로 작성된 설치 및 업그레이드 명령이 어떻게 다른지 차이점을 확인하십시오.

ESXi 5.x에서는 호스트가 부팅될 때 설치 이미지가 호스트 RAM에 직접 로드되기 때문에 설치 스크립트에 설치 미디어 위치를 포함할 필요가 없습니다.

ESXi 5.x는 스크립트로 작성된 설치뿐 아니라 스크립트로 작성된 업그레이드도 지원합니다.

명령의 차이점은 아래에 요약되어 있습니다.

accepteula 또는 vmaccepteula

ESXi에서만 사용할 수 있습니다.

autopart

더 이상 사용되지 않으며 대신 install, upgrade 또는 installorupgrade를 사용해야 합니다.

auth 또는 authconfig

ESXi 5.x에서 지원되지 않습니다.

bootloader

ESXi 5.x에서 지원되지 않습니다.

esxlocation

ESXi에서 폐기 예정이며 더 이상 사용되지 않습니다.

방화벽

ESXi 5.x에서 지원되지 않습니다.

firewallport

ESXi 5.x에서 지원되지 않습니다.

install, installorupgrade, upgrade

더 이상 사용되지 않는 autopart 명령을 대신합니다. 이러한 명령 중 하나를 사용하여 파티션을 처리할 디스크를 지정하고 part 명령을 사용하여 vmfs 데이터스토어를 생성합니다. installorupgradeupgradeESXi 5.x에서 새로 지원되는 명령입니다.

serialnum

ESXi 5.0.x에서는 더 이상 사용되지 않으며, ESXi 5.1에서 지원됩니다.

vmserialnum

ESXi 5.0.x에서는 더 이상 사용되지 않으며, ESXi 5.1에서 지원됩니다.

표준 시간대

ESXi 5.x에서 지원되지 않습니다.

virtualdisk

ESXi 5.x에서 지원되지 않습니다.

zerombr

ESXi 5.x에서 지원되지 않습니다.

%firstboot

--level 옵션이 ESXi 5.x에서 지원되지 않습니다.

%packages

ESXi 5.x에서 지원되지 않습니다.