사용자 지정 VIB가 포함된 호스트를 업그레이드할 경우 동일한 VIB가 업그레이드 ISO 파일에 포함되어 있지 않으면 업그레이드 시 오류 메시지가 표시됩니다.

호스트에 타사 드라이버 또는 관리 에이전트와 같은 사용자 지정 VIB가 설치되어 있을 수 있습니다. 예를 들어 ESX/ESXi 4.x 호스트에는 Cisco Nexus 1000V VEM 또는 EMC PowerPath 모듈이 있을 수 있습니다. ESXi 5.x 아키텍처는 ESX/ESXi 4.x와 다르므로 ESX/ESXi 4.x에서 ESXi 5.x로 업그레이드할 때 사용자 지정된 타사 소프트웨어 패키지(VIB)는 마이그레이션할 수 없습니다. 업그레이드 ISO에는 없는 사용자 지정 VIB가 포함된 4.x 호스트를 업그레이드할 경우 ESXi 설치 관리자에서는 누락된 VIB가 나열된 오류 메시지를 표시합니다.

타사 사용자 지정 기능을 호스트 업그레이드의 일부로 마이그레이션하려면 ESXi Image Builder를 사용하여 누락된 VIB를 포함하는 사용자 지정 ESXi ISO 이미지를 만듭니다. Image Builder를 사용하여 사용자 지정 ISO를 만드는 방법에 대한 자세한 내용은 vSphere 설치 및 설정 설명서에서 ESXi Image Builder 사용에 대한 정보를 참조하십시오.

타사 소프트웨어를 포함하지 않고 버전 4.x ESX/ESXi 호스트를 업그레이드하려면 다음 작업 중 하나를 수행합니다.

  • 타사 소프트웨어를 제거합니다. vSphere Update Manager를 사용하는 경우 업데이트 적용 프로세스 중에 타사 소프트웨어 모듈을 제거하는 옵션을 선택합니다. vSphere Update Manager를 사용하여 업그레이드하는 방법에 대한 자세한 내용은 VMware vSphere Update Manager 설치 및 관리를 참조하십시오.

  • 마이그레이션 적용 옵션을 선택하여 호스트 업그레이드 중에 오류 메시지가 나타나지 않도록 합니다.

주의:

이 두 옵션 중 하나를 사용하면 업그레이드된 호스트가 제대로 부팅되지 않거나, 시스템 안정성이 떨어지거나, 기능이 손실될 수 있습니다. 시스템이 타사 VIB에 상당히 의존하고 있지 않은지 확인합니다. 이러한 문제는 처음 부팅할 때 해결해야 하며 나중에는 해결할 수 없습니다. 예를 들어 시스템에 부팅 시 사용하는 NIC에 맞는 사용자 지정 드라이버가 필요할 수 있습니다.

5.0.x 호스트를 업그레이드하는 경우에는 ESXi 설치 관리자 ISO에 포함되지 않은, 호스트의 지원되는 사용자 지정 VIB가 마이그레이션됩니다. 호스트 또는 설치 관리자 .ISO에 충돌을 유발하고 업그레이드를 방해하는 VIB가 포함된 경우 문제가 되는 VIB를 알리는 오류 메시지가 표시됩니다. VIB를 제거하고 업그레이드를 다시 시도하거나 ESXI Image Builder CLI를 사용하여 충돌을 해결하는 사용자 지정 설치 관리자 .ISO를 생성할 수 있습니다. forcemigrate 옵션은 사용할 수 없습니다.

ESX/ESXi 4.1 업그레이드 1 또는 ESX/ESXi 4.0 업그레이드 3을 실행하는 호스트를 업그레이드하면 사용자 지정 VIB가 설치되어 있지 않더라도 1에 나열된 VIB에 대한 오류 메시지가 표시됩니다. 작동이 정상적이거나 시스템이 이러한 VIB에 의존하지 않는 것으로 확인된 경우에는 주의를 무시하고 업그레이드를 계속할 수 있습니다.

표 1. ESXi 5.x로 마이그레이션할 수 없는 ESX/ESXi 4.0 U3 및 4.1 U1 타사 VIB

ESX/ESXi 릴리스

공지 ID

VIB ID

4.1 업그레이드 1

ESX410-201101224-UG

cross_vmware-esx-drivers-net-vxge_400.2.0.28.21239-1OEM

이 Neterion 드라이버가 필요한 하드웨어가 시스템에 없는 경우 오류 메시지를 무시해도 됩니다.

4.1 업그레이드 1

ESX410-201101223-UG

cross_vmware-esx-drivers-scsi-3w-9xxx_400.2.26.08.036vm40-1OEM

이 3ware 드라이버가 필요한 하드웨어가 시스템에 없는 경우 오류 메시지를 무시해도 됩니다.

4.0 업그레이드 3

ESX400-201105213-UG

cross_vmware-esx-drivers-scsi-3w-9xxx_400.2.26.08.036vm40-1OEM

이 3ware 드라이버가 필요한 하드웨어가 시스템에 없는 경우 오류 메시지를 무시해도 됩니다.