가상 시스템을 생성하거나 기존 가상 시스템을 업그레이드할 때 가상 시스템 호환성 설정을 사용하여 가상 시스템을 실행할 수 있는 ESXi 호스트 버전을 선택합니다.

호환성 설정에 따라 가상 시스템에서 사용할 수 있는 가상 하드웨어가 결정되며, 이는 호스트에서 사용할 수 있는 물리적 하드웨어에 해당됩니다. 가상 하드웨어에는 BIOS와 EFI, 사용 가능한 가상 PCI 슬롯, 최소 CPU 수, 최대 메모리 구성 및 기타 특성이 포함됩니다. 새 가상 하드웨어 기능은 일반적으로 vSphere 주 버전이나 부 버전과 함께 매년 한 번씩 릴리스됩니다.

각 가상 시스템 호환성 수준은 5개 이상의 vSphere 주 버전 또는 부 버전을 지원합니다. 예를 들어 ESXi 3.5 이상과 호환되는 가상 시스템은 ESXi 3.5, ESXi 4.0, ESXi 4.1, ESXi 5.0, ESXi 5.1 및 ESXi 5.5에서 실행될 수 있습니다.

표 1. 가상 시스템 호환성 옵션

호환성

설명

ESXi 5.5 이상

이 가상 시스템(하드웨어 버전 10)은 ESXi 5.5 이상과 호환됩니다.

ESXi 5.1 이상

이 가상 시스템(하드웨어 버전 9)은 ESXi 5.1 및 ESXi 5.5와 호환됩니다.

ESXi 5.0 이상

이 가상 시스템(하드웨어 버전 8)은 ESXi 5.0, ESXi 5.1 및 ESXi 5.5와 호환됩니다.

ESX/ESXi 4.0 이상

이 가상 시스템(하드웨어 버전 7)은 ESX/ESXi 4.0, ESX/ESXi 4.1, ESXi 5.0, ESXi 5.1 및 ESXi 5.5와 호환됩니다.

ESX/ESXi 3.5 이상

이 가상 시스템(하드웨어 버전 4)은 ESX/ESXi 3.5, ESX/ESXi 4.0, ESX/ESXi 4.1, ESXi 5.1 및 ESXi 5.5와 호환됩니다. 또한 VMware Server 1.0 이상과도 호환됩니다. ESXi 5.0에서는 ESX/ESXi 3.5 이상과 호환되는 가상 시스템을 생성할 수 없지만, 호환성 수준이 다른 호스트에 생성할 경우에는 이러한 가상 시스템을 실행할 수 있습니다.

ESX Server 2.x 이상

이 가상 시스템(하드웨어 버전 3)은 ESX Server 2.x, ESX/ESXi 3.5, ESX/ESXi 4.x 및 ESXi 5.0과 호환됩니다. ESX Server 2.x와 호환되는 가상 시스템은 생성, 편집, 켜기, 복제 또는 마이그레이션할 수 없습니다. 이 시스템은 등록하거나 업그레이드할 수만 있습니다.

호환 대상 드롭다운 메뉴에 표시되는 호환성 설정은 생성하고 있는 가상 시스템의 기본값입니다. 다음 요인에 따라 기본 가상 시스템 호환성이 결정됩니다.

  • 가상 시스템이 생성된 ESXi 호스트 버전

  • 기본 가상 시스템 호환성이 설정된 인벤토리 개체(호스트, 클러스터, 데이터 센터 등)

기본 호환성을 적용하거나 다른 설정을 선택할 수 있습니다. 항상 최신 ESXi 호스트 버전을 선택할 필요는 없습니다. 이전 버전을 선택하면 유연성을 개선할 수 있으며, 다음과 같은 경우에 유용합니다.

  • 가상 환경에서 테스팅 및 배포를 표준화하려는 경우

  • 최신 버전의 호스트 기능이 필요하지 않은 경우

  • 이전 호스트와 호환성을 유지하려는 경우

가상 시스템을 생성할 때는 가상 시스템이 실행될 환경을 고려하여 여러 호환성 전략의 이점을 평가하십시오. 각 가상 시스템 호환성 선택에 내재하는 유연성을 보여 주는 다음 시나리오에 대한 옵션을 고려하십시오.

환경의 개체

호환성

결과

ESXi 5.0 및 ESXi 4.x 호스트를 포함하는 클러스터

ESX/ESXi 4.0 이상

ESXi 5.0과 같은 클러스터의 다른 호스트에서 실행할 가상 시스템의 기능을 유지합니다.

최신 가상 하드웨어 기능에 액세스하지 못할 수도 있습니다.

ESXi 5.0 및 ESXi 4.x 호스트를 포함하는 클러스터

ESXi 5.0 이상

ESXi 4.x에서 제공되지 않는 가상 하드웨어 기능에 액세스할 수 있습니다. ESXi 5.1 이상 호스트에서도 실행할 수 있습니다.

  • 이 가상 시스템을 ESXi 4.x 호스트로 마이그레이션할 수 없습니다.

  • 이 가상 시스템은 ESXi 5.1에서 실행되는 가상 시스템에서 사용할 수 있는 기능 중 일부가 없습니다. 예를 들어 64개 가상 프로세서를 사용할 수 없습니다.

ESXi 5.5 호스트

ESXi 5.5 이상

최신 가상 하드웨어 기능에 액세스할 수 있지만 이전 호스트와 리소스를 공유할 수 없습니다.

가상 시스템이 이전 ESX/ESXi 호스트 버전과 호환성을 유지할 필요가 없는 경우에는 가상 시스템을 업그레이드할 수 있습니다.

  • 가상 시스템을 ESX/ESXi 3.5 호스트와 호환되도록 유지하려면 ESX/ESXi 3.5 호스트에서 가상 시스템을 업그레이드하여 가상 시스템이 버전 4로 업그레이드되도록 합니다.

  • 가상 시스템이 ESX/ESXi 4.x 호스트와 호환되도록 유지하려면 ESX/ESXi 4.x 호스트에서 가상 시스템을 업그레이드하여 가상 시스템이 버전 7로 업그레이드되도록 합니다.