설치 및 업그레이드 사전 확인 스크립트는 테스트를 실행하여 호스트 시스템에서 설치, 업그레이드 또는 마이그레이션 실패를 초래할 수 있는 문제를 확인합니다.

대화형 설치, 업그레이드 및 마이그레이션의 경우 오류 또는 주의는 설치 관리자의 마지막 패널에 표시됩니다. 이 패널에서 설치 또는 업그레이드를 확인하거나 취소할 수 있습니다. 스크립트로 작성된 설치, 업그레이드 또는 마이그레이션의 경우에는 오류 또는 주의가 설치 로그 파일에 기록됩니다.

vSphere Update Manager에서는 이러한 오류 또는 주의에 대한 사용자 지정 메시지를 제공합니다. Update Manager 호스트 업그레이드 검색 중 사전 확인 스크립트에서 반환된 원래 오류 및 주의를 보려면 Update Manager 로그 파일인 vmware-vum-server-log4cpp.log를 검토하십시오.

표 1. 설치 및 업그레이드 사전 확인 스크립트에서 반환되는 오류 및 주의 코드

오류 또는 주의

설명

64BIT_LONGMODESTATUS

호스트 프로세서는 64비트여야 합니다.

COS_NETWORKING

주의. vmkernel의 동일한 서브넷에 해당 주소가 없는 사용 가능한 서비스 콘솔 가상 NIC에서 IPv4 주소를 찾았음을 나타냅니다. 이러한 경우가 발생할 때마다 개별적으로 주의가 나타납니다.

CPU_CORES

호스트에는 최소 두 개의 코어가 있어야 합니다.

DISTRIBUTED_VIRTUAL_SWITCH

호스트에 Cisco의 VEM(Virtual Ethernet Module) 소프트웨어가 있는 경우 테스트에서는 업그레이드에 VEM 소프트웨어도 포함되어 있는지 확인합니다. 또한 테스트는 업그레이드가 호스트에 있는 기존 버전과 동일한 버전의 Cisco VSM(Virtual Supervisor Module)을 지원하는지 확인합니다. 이 소프트웨어가 없거나 다른 버전의 VSM과 호환되는 경우 테스트에서는 주의를 반환합니다. 결과에는 업그레이드 ISO에 필요한 VEM 소프트웨어 버전과 현재 발견된 버전(있는 경우)이 표시됩니다. ESXi Image Builder CLI를 사용하여 적절한 버전의 VEM 소프트웨어가 포함된 사용자 지정 설치 ISO를 생성할 수 있습니다.

HARDWARE_VIRTUALIZATION

주의. 호스트 프로세서에 하드웨어 가상화 기능이 없거나 호스트 BIOS에서 하드웨어 가상화 기능이 설정되어 있지 않은 경우 호스트 성능이 저하됩니다. 호스트 시스템 부팅 옵션에서 하드웨어 가상화를 사용하도록 설정하십시오. 하드웨어 벤더의 설명서를 참조하십시오.

MD5_ROOT_PASSWORD

이 테스트에서는 루트 암호가 MD5 형식으로 인코딩되었는지 확인합니다. 암호가 MD5 형식으로 인코딩되지 않은 경우에는 8자까지만 의미가 있습니다. 이 경우 처음 8자 이후의 문자는 업그레이드 후 더 이상 인증되지 않으므로 보안 문제가 발생할 수 있습니다. 이 문제를 해결하려면 VMware 기술 자료 문서 1024500을 참조하십시오.

MEMORY_SIZE

업그레이드하려면 호스트에 지정한 크기의 메모리가 있어야 합니다.

PACKAGE_COMPLIANCE

vSphere Update Manager만 해당. 이 테스트에서는 업그레이드 ISO에 포함된 소프트웨어와 호스트의 기존 소프트웨어를 비교하여 호스트가 성공적으로 업그레이드되었는지 확인합니다. 패키지 중 일부가 누락되었거나 업그레이드 ISO의 패키지보다 이전 버전인 경우, 테스트에서는 오류를 반환하고 호스트에 있는 소프트웨어와 업그레이드 ISO에서 발견된 소프트웨어를 알려 줍니다.

PARTITION_LAYOUT

업그레이드되는 디스크에 VMFS 파티션이 하나뿐이고 이 VMFS 파티션이 섹터 1843200 이후에 시작되어야 하는 경우에만 소프트웨어를 업그레이드하거나 마이그레이션할 수 있습니다.

POWERPATH

이 테스트에서는 CIM 모듈과 커널 모듈로 구성된 EMC PowerPath 소프트웨어가 설치되어 있는지 확인합니다. 호스트에 이러한 구성 요소 중 하나가 있는 경우 테스트에서는 다른 일치하는 구성 요소(CIM, vmkernel 및 모듈)도 업그레이드에 있는지 확인합니다. 구성 요소가 없으면 테스트에서는 업그레이드 ISO에 필요한 PowerPath 구성 요소와 현재 발견된 구성 요소(있는 경우)를 알려 주는 주의를 반환합니다.

PRECHECK_INITIALIZE

이 테스트에서는 사전 확인 스크립트가 실행 가능한지를 확인합니다.

SANE_ESX_CONF

/etc/vmware/esx.conf 파일이 호스트에 있어야 합니다.

SPACE_AVAIL_ISO

vSphere Update Manager만 해당. 호스트 디스크에는 설치 관리자 CD 또는 DVD의 내용을 저장하는 데 사용할 수 있는 공간이 충분히 있어야 합니다.

SPACE_AVAIL_CONFIG

vSphere Update Manager만 해당. 호스트 디스크에는 재부팅 사이에 레거시 구성을 저장하는 데 사용할 수 있는 충분한 공간이 있어야 합니다.

SUPPORTED_ESX_VERSION

버전 5.5 또는 6.0 ESXi 호스트에서만 ESXi 6.5로 업그레이드하거나 마이그레이션할 수 있습니다.

TBOOT_REQUIRED

이 메시지는 vSphere Update Manager 업그레이드에만 적용됩니다. 호스트 시스템이 신뢰할 수 있는 부팅 모드(tboot)에서 실행 중이지만 ESXi 업그레이드 ISO에 tboot VIB가 없는 경우 이 오류가 발생하면서 업그레이드가 실패합니다. 이 테스트는 호스트의 보안 수준이 낮아지게 할 수 있는 업그레이드를 방지합니다.

UNSUPPORTED_DEVICES

주의. 이 테스트에서는 지원되지 않는 디바이스를 확인합니다. 일부 PCI 디바이스는 ESXi 6.5에서 지원되지 않습니다.

UPDATE_PENDING

이 테스트에서는 재부팅이 필요한 VIB 설치를 호스트에서 확인합니다. 이러한 VIB가 하나 이상 설치되어 있지만 호스트가 아직 재부팅되지 않았으면 이 테스트가 실패합니다. 이러한 경우 사전 확인 스크립트에서는 호스트에 현재 설치된 패키지를 정확하게 확인할 수 없으므로 사전 확인 테스트의 나머지 부분만으로는 업그레이드가 안전한지 여부를 확실하게 확인할 수 없습니다.

이 오류가 발생하면 호스트를 재시작하고 업그레이드를 다시 시도하십시오.