vSAN 데이터스토어에 데이터를 저장하는 가상 시스템의 상태가 vSAN 클러스터의 장애 때문에 비준수, 액세스할 수 없음 또는 분리됨으로 표시됩니다.
문제
vSAN 데이터스토어의 가상 시스템이 vSAN 클러스터의 장애를 나타내는 다음 상태 중 하나에 있습니다.
- 가상 시스템이 규정을 준수하지 않으며 해당 개체 중 일부의 규정 준수 상태가 비준수입니다. vSAN에서 가상 시스템의 규정 준수 검사 항목을 참조하십시오.
- 가상 시스템 개체가 액세스할 수 없거나 링크가 끊어진 상태입니다. 구성 요소의 장애 상태 검토 항목을 참조하십시오.
개체 복제본을 다른 호스트에서 사용 가능한 경우 vSAN은 가상 시스템의 I/O 작업을 복제본으로 전달합니다.
원인
가상 시스템의 개체가 할당된 VM 스토리지 정책의 요구 사항을 더 이상 충족할 수 없는 경우 vSAN은 이를 비준수로 간주합니다. 예를 들어 호스트의 연결이 일시적으로 끊길 수 있습니다. vSAN에서 문제를 나타내는 개체 상태 항목을 참조하십시오.
vSAN이 전체 복제본 또는 개체 투표의 50% 이상을 찾을 수 없는 경우, 가상 시스템은 액세스할 수 없는 상태가 됩니다. VM 홈 네임스페이스가 손상되어 .vmx 파일에 액세스할 수 없음을 vSAN이 감지하면, 가상 시스템은 링크가 끊긴 상태가 됩니다. vSAN에서 장애 발생 시 가상 시스템의 액세스 지원 항목을 참조하십시오.
해결책
클러스터에 충분한 리소스가 포함되어 있으면 vSAN은 장애가 영구적인 경우 손상된 개체를 자동으로 복구합니다.
클러스터에 리소스가 부족하여 손상된 개체를 재구축할 수 없는 경우에는 클러스터의 공간을 확장하십시오. "VMware vSAN 관리" 항목을 참조하십시오.