경우에 따라 vSphere Auto Deploy 데이터베이스에 문제가 발생할 수 있습니다. 가장 효율적인 복구 옵션은 기존의 데이터베이스 파일을 최신 백업으로 교체하는 것입니다.

문제

사용자 환경에서 vSphere Auto Deploy를 사용하여 ESXi 호스트를 프로비저닝할 때 vSphere Auto Deploy 데이터베이스에 문제가 발생할 수 있습니다.
중요: 자주 발생하는 문제는 아닙니다. 현재 데이터베이스 파일을 교체하기 전에 다른 모든 vSphere Auto Deploy 문제 해결 전략을 수행하십시오. 선택한 백업 이후에 생성된 규칙이나 연결은 손실됩니다.

원인

이 문제는 vSphere Auto Deploy로 프로비저닝한 호스트에서만 발생합니다.

해결책

  1. vSphere Auto Deploy 서버 서비스를 중지합니다.
  2. vSphere Client에서 [vSphere Auto Deploy] 페이지로 이동하여 vSphere Auto Deploy 로그를 찾습니다.
  3. 로그에서 다음 메시지를 확인합니다.
    DatabaseError: database disk image is malformed.

    이 메시지가 표시되면 기존의 데이터베이스를 최신 백업으로 교체합니다.

  4. vSphere Auto Deploy 데이터 디렉토리(/var/lib/rbd)로 이동합니다.
    디렉토리에는 db 파일 및 db- yyy- mm- dd 백업 파일이 포함됩니다.
  5. 현재 db 파일의 이름을 바꿉니다.
    VMware 지원에서 지원을 위해 해당 파일을 요청할 수 있습니다.
  6. 최신 백업의 이름을 db로 바꿉니다.
  7. vSphere Auto Deploy 서버 서비스를 다시 시작합니다.
  8. 그래도 로그에 해당 메시지가 표시되면 데이터베이스 오류 없이 vSphere Auto Deploy가 작동할 때까지 그 다음 최신 백업을 사용하여 위의 단계를 반복합니다.