포트 그룹 구성 후 vSphere Distributed Switch의 호스트가 vCenter Server에 연결하지 못합니다.

문제

관리 네트워크의 VMkernel 어댑터가 포함된 vSphere Distributed Switch에서 포트 그룹의 네트워킹 구성을 변경하면 이 스위치의 호스트와 vCenter Server의 연결이 끊어집니다. vSphere Client에서 호스트의 상태가 응답하지 않음으로 나타납니다.

원인

네트워킹 롤백이 비활성화된 vCenter Server의 vSphere Distributed Switch에서는 관리 네트워크의 VMkernel 어댑터가 포함된 포트 그룹이 vCenter Server에서 잘못 구성되고 이 잘못된 구성이 스위치의 호스트에 전파됩니다.
참고: vSphere 네트워킹에서는 기본적으로 롤백이 사용되도록 설정되어 있습니다. 하지만 vCenter Server 수준에서 롤백을 활성화하거나 비활성화할 수 있습니다. 자세한 내용은 " vSphere 네트워킹" 설명서를 참조하십시오.

해결책

  1. 영향받는 호스트에 대한 DCUI(Direct Console User Interface)에서 네트워크 복원 옵션 메뉴의 vDS 복원 옵션을 사용하여 관리 네트워크의 VLAN에 대한 ID와 업링크를 구성합니다.
    DCUI에서 사용 후 삭제 로컬 포트가 생성되고 VLAN 및 업링크 구성이 포트에 적용됩니다. 또한 DCUI에서 새 호스트 로컬 포트를 사용하도록 관리 네트워크의 VMkernel 어댑터를 변경하여 vCenter Server와의 연결을 복원합니다.

    호스트가 vCenter Server에 다시 연결된 후 vSphere Client에서 스위치에 있는 일부 호스트의 네트워킹 구성이 vSphere Distributed Switch에 저장된 구성과 다르다는 주의가 표시됩니다.

  2. vSphere Client에서 관리 네트워크의 분산 포트 그룹을 올바른 설정으로 구성합니다.
    상황 솔루션
    포트 그룹 구성을 한 번만 변경했을 경우 포트 그룹의 구성을 한 단계 뒤로 롤백할 수 있습니다. 포트 그룹을 마우스 오른쪽 버튼으로 클릭하고 구성 복원을 클릭한 후 이전 구성으로 복원을 선택합니다.
    유효한 포트 그룹 구성을 백업했을 경우

    백업 파일을 사용하여 포트 그룹의 구성을 복원할 수 있습니다. 포트 그룹을 마우스 오른쪽 버튼으로 클릭하고 구성 복원을 클릭한 후 파일에서 구성 복원을 선택합니다.

    또한 스위치의 백업 파일을 사용하여 포트 그룹을 포함한 전체 스위치의 구성을 복원할 수도 있습니다.

    두 단계 이상의 구성을 수행했고 백업 파일이 없을 경우 포트 그룹에 유효한 설정을 수동으로 제공해야 합니다.
    네트워킹 롤백, 복구 및 복원에 대한 자세한 내용은 " vSphere 네트워킹" 설명서를 참조하십시오.
  3. 호스트 추가 및 관리 마법사를 사용하여 관리 네트워크의 VMkernel 어댑터를 호스트 사용 후 삭제 로컬 포트에서 스위치의 분산 포트로 마이그레이션합니다.
    분산 포트와 달리 VMkernel의 사용 후 삭제 로컬 포트 ID는 숫자가 아닙니다.

    호스트 추가 및 관리 마법사를 통해 VMkernel 어댑터를 처리하는 방법에 대한 자세한 내용은 "vSphere 네트워킹" 설명서를 참조하십시오.

  4. vCenter Server의 분산 포트 그룹 및 VMkernel 어댑터 구성을 호스트에 적용합니다.
    • vCenter Server의 올바른 분산 포트 그룹 및 VMkernel 어댑터 구성을 호스트에 푸시합니다.
      1. vSphere Client에서 호스트로 이동합니다.
      2. 구성 탭에서 네트워킹을 클릭합니다.
      3. 가상 스위치 목록에서 Distributed Switch를 선택하고 호스트에서 선택한 Distributed Switch 상태 수정을 클릭합니다.
    • vCenter Server가 다음 24시간 내에 설정을 적용할 때까지 기다립니다.