NSX Advanced Load Balancer 문제를 해결하기 위해 지원 번들을 수집할 수 있습니다. VMware 지원에서 지원 번들을 요청할 수도 있습니다.

지원 번들을 생성하면 디버그 로그에 대한 단일 파일이 생성되어 다운로드할 수 있습니다.

프로시저

  1. NSX Advanced Load Balancer Controller 대시보드에서 왼쪽 상단 모서리에 있는 메뉴를 클릭하고 관리를 선택합니다.
  2. 관리 섹션에서 시스템을 선택합니다.
  3. 시스템 화면에서 기술 지원을 선택합니다.
  4. 진단 번들을 생성하려면 기술 지원 생성을 클릭합니다.
  5. 기술 지원 생성 창에서 디버그 로그 유형을 선택하고 생성을 클릭합니다.
  6. 번들이 생성되면 다운로드 아이콘을 클릭하여 시스템에 다운로드합니다.
    로그 수집에 대한 자세한 내용은 https://avinetworks.com/docs/21.1/collecting-tech-support-logs/ 항목을 참조하십시오.

NSX Advanced Load Balancer 구성이 적용되지 않음

감독자를 배포하면 배포가 완료되지 않고 NSX Advanced Load Balancer 구성이 적용되지 않습니다.

문제

사설 CA(인증 기관) 서명 인증서를 제공하는 경우 NSX Advanced Load Balancer 구성이 적용되지 않습니다.

감독자에서 실행되는 NCP 포드 중 하나의 로그 파일에 Unable to find certificate chain 오류 메시지가 표시될 수 있습니다.

  1. 감독자 VM에 로그인합니다.
  2. kubectl get pods -A XX 명령을 사용하여 모든 Pod를 나열합니다.
  3. 감독자의 모든 NCP 포드에서 로그를 가져옵니다.

    kubectl -n vmware-system-nsx logs nsx-ncp-<id> | grep -i alb

원인

Java SDK는 NCP와 NSX Advanced Load Balancer Controller 간의 통신을 설정하는 데 사용됩니다. 이 오류는 NSX 신뢰 저장소가 Java 인증서 신뢰 저장소와 동기화되지 않은 경우 발생합니다.

해결책

  1. NSX Advanced Load Balancer에서 루트 CA 인증서를 내보내고 NSX Manager에 저장합니다.
  2. 루트 사용자로 NSX Manager에 로그인합니다.
  3. 모든 NSX Manager 노드에서 다음 명령을 순차적으로 실행합니다.
    keytool -importcert -alias startssl -keystore /usr/lib/jvm/jre/lib/security/cacerts -storepass changeit -file <ca-file-path>

    경로를 찾을 수 없으면 keytool -importcert -alias startssl -keystore /usr/java/jre/lib/security/cacerts -storepass changeit -file <ca-file-path>를 실행합니다.

    sudo cp <ca-file-path> /usr/local/share/ca-certificates/
    sudo update-ca-certificates
    service proton restart
    참고: 동일한 단계를 수행하여 중간 CA 인증서를 할당할 수 있습니다.
  4. 감독자 배포가 완료될 때까지 기다리거나 배포가 수행되지 않으면 다시 배포합니다.

ESXi 호스트를 유지 보수 모드로 전환할 수 없음

업그레이드를 수행하려는 경우 ESXi 호스트를 유지 보수 모드로 전환합니다.

문제

ESXi 호스트를 유지 보수 모드로 전환할 수 없으며 ESXiNSX 업그레이드에 영향을 미칠 수 있습니다.

원인

이 문제는 ESXi 호스트에 전원이 켜진 상태의 서비스 엔진이 있는 경우에 발생할 수 있습니다.

해결책

  • ESXi가 유지 보수 모드로 전환될 수 있도록 서비스 엔진의 전원을 끕니다.

IP 주소 문제 해결

외부 IP 할당 문제가 발생하면 다음 문제 해결 팁을 따르십시오.

IP 주소 문제는 다음과 같은 이유로 발생할 수 있습니다.
  • 게이트웨이 및 수신과 같은 Kubernetes 리소스가 AKO에서 외부 IP를 가져오지 않습니다.
  • Kubernetes 리소스에 할당된 외부 IP에 연결할 수 없습니다.
  • 잘못 할당된 외부 IP입니다.

Kubernetes 리소스가 AKO에서 외부 IP를 가져오지 않음

이 오류는 AKO가 NSX Advanced Load Balancer Controller에서 해당 가상 서비스를 생성할 수 없을 때 발생합니다.

AKO 포드가 실행 중인지 확인합니다. 포드가 실행 중인 경우 AKO 컨테이너 로그에서 오류를 확인합니다.

Kubernetes 리소스에 할당된 외부 IP에 연결할 수 없음

이 문제는 다음과 같은 이유로 발생할 수 있습니다.
  • 외부 IP를 즉시 사용할 수 없지만 생성 후 몇 분 내에 트래픽 수락이 시작됩니다. 이 문제는 가상 서비스 배치를 위해 새로운 서비스 엔진 생성이 트리거될 때 발생합니다.
  • 해당 가상 서비스에 오류가 표시되어 외부 IP를 사용할 수 없습니다.

풀에 서버가 없는 경우 가상 서비스가 오류를 나타내거나 빨간색으로 나타날 수 있습니다. 이 문제는 Kubernetes 게이트웨이 또는 수신 리소스가 끝점 개체를 가리키지 않는 경우 발생할 수 있습니다.

끝점을 보려면 kubectl get endpoints -n <servce_namespace> 명령을 실행하고 선택기 레이블 문제를 해결합니다.

상태 모니터에 풀 서버의 상태가 빨간색으로 표시되면 풀이 오류 상태로 나타날 수 있습니다.

이 문제를 해결하려면 다음 단계 중 하나를 수행하십시오.
  • 풀 서버 또는 Kubernetes 포드가 구성된 포트에서 수신 대기 중인지 확인합니다.
  • NSX DFW 방화벽에 서비스 엔진의 수신 또는 송신 트래픽을 차단하는 삭제 규칙이 없는지 확인합니다.
  • Kubernetes 환경에 서비스 엔진의 수신 또는 송신 트래픽을 차단하는 네트워크 정책이 없는지 확인합니다.
서비스 엔진 문제에는 다음이 포함됩니다.
  1. 서비스 엔진 생성이 실패합니다.
    서비스 엔진 생성은 다음과 같은 이유로 인해 실패할 수 있습니다.
    • 리소스가 부족한 라이센스가 NSX Advanced Load Balancer Controller에서 사용됩니다.
    • 서비스 엔진 그룹에서 생성된 서비스 엔진 수가 최대 제한에 도달했습니다.
    • 서비스 엔진 데이터 NIC가 IP를 획득하지 못했습니다.
  2. 서비스 엔진 생성이 실패하고 Insufficient licensable resources available 오류 메시지가 표시됩니다.

    이 오류는 리소스가 부족한 라이센스를 사용하여 서비스 엔진을 생성한 경우에 발생합니다.

    리소스 할당량이 더 큰 라이센스를 가져와서 NSX Advanced Load Balancer Controller에 할당하십시오.

  3. 서비스 엔진 생성이 실패하고 Reached configuration maximum limit 오류 메시지가 표시됩니다.

    이 오류는 서비스 엔진 그룹에서 생성된 서비스 엔진 수가 최대 제한에 도달한 경우에 발생합니다.

    이 오류를 해결하려면 다음 단계를 수행하십시오.
    1. NSX Advanced Load Balancer Controller 대시보드에서 인프라 > 클라우드 리소스 > 서비스 엔진 그룹을 선택합니다.
    2. IP 트래픽 장애가 발생한 감독자와 이름이 동일한 서비스 엔진 그룹을 찾아 편집 아이콘을 클릭합니다.
    3. 서비스 엔진 수에 더 높은 값을 구성합니다.
  4. 서비스 엔진 데이터 NIC가 IP를 획득하지 못했습니다.
    이 오류는 DHCP IP 풀이 다음 이유 중 하나로 인해 고갈된 경우 발생할 수 있습니다.
    • 대규모 배포를 위해 너무 많은 서비스 엔진이 생성되었습니다.
    • 서비스 엔진을 NSX Advanced Load Balancer UI 또는 vSphere Client에서 직접 삭제한 경우, 이렇게 삭제하면 DHCP 풀에서 DHCP 주소가 해제되지 않아서 리스 할당 실패가 발생합니다.

외부 IP가 잘못 할당됨

이 오류는 서로 다른 네임스페이스에 있는 두 개의 수신이 동일한 호스트 이름을 공유하는 경우 발생합니다. 구성을 확인하고 서로 다른 네임스페이스에 있는 두 개의 수신에 동일한 이름이 지정되지 않는지 확인합니다.

트래픽 장애 문제 해결

NSX Advanced Load Balancer를 구성한 후 트래픽 장애가 발생합니다.

문제

LB 유형의 서비스에 대한 끝점이 다른 네임스페이스에 있는 경우 트래픽 장애가 발생할 수 있습니다.

원인

NSX Advanced Load Balancer로 구성된 vSphere IaaS control plane 환경에서, 네임스페이스에 전용 Tier-1 게이트웨이가 있고 각 Tier-1 게이트웨이에는 동일한 CIDR을 가진 서비스 엔진 세그먼트가 있습니다. NSX Advanced Load Balancer 서비스가 하나의 네임스페이스에 있고 끝점이 다른 네임스페이스에 있는 경우 트래픽 장애가 발생할 수 있습니다. 이 장애는 NSX Advanced Load Balancer가 서비스에 외부 IP를 할당하고 외부 IP에 대한 트래픽이 실패하기 때문에 발생합니다.

해결책

  • North-South 트래픽을 허용하려면 NSX Advanced Load Balancer 서비스 네임스페이스의 SNAT IP로부터의 수신을 허용하는 분산 방화벽 규칙을 생성합니다.

NSX 백업 및 복원으로 인한 문제 해결

NSX 백업 및 복원으로 인해 NSX Advanced Load Balancer에서 제공된 모든 외부 IP에 대한 트래픽 장애가 발생할 수 있습니다.

문제

NSX의 백업 및 복원을 수행하면 트래픽 장애가 발생할 수 있습니다.

원인

이런 장애는 복원 후 서비스 엔진 NIC가 다시 작동하지 않아 IP 풀이 다운된 것으로 표시되기 때문에 발생합니다.

해결책

  1. NSX Advanced Load Balancer Controller 대시보드에서 인프라 > 클라우드를 선택합니다.
  2. 클라우드를 선택하고 변경하지 않고 저장하고 상태가 녹색이 될 때까지 기다립니다.
  3. 모든 가상 서비스를 비활성화합니다.
    NSX Advanced Load Balancer Controller가 모든 서비스 엔진에서 오래된 NIC를 제거할 때까지 기다립니다.
  4. 모든 가상 서비스를 사용하도록 설정합니다.
    가상 서비스 상태가 녹색으로 표시됩니다.
    트래픽 장애가 지속되면 NSX Manager에서 정적 경로를 재구성합니다.

NSX 백업 및 복원 후 오래된 Tier-1 세그먼트

NSX 백업 및 복원으로 오래된 Tier-1 세그먼트를 복원할 수 있습니다.

문제

NSX 백업 및 복원 절차 후에 서비스 엔진 NIC가 있는 오래된 Tier-1 세그먼트가 정리되지 않습니다.

원인

NSX 백업 후 네임스페이스가 삭제되면 복원 작업에서 NSX Advanced Load Balancer Controller 서비스 엔진 NIC와 연결된 오래된 Tier-1 세그먼트를 복원합니다.

해결책

  1. NSX Manager에 로그인합니다.
  2. 네트워킹 > 세그먼트를 선택합니다.
  3. 삭제된 네임스페이스와 연결된 오래된 세그먼트를 찾습니다.
  4. 포트/인터페이스 섹션에서 오래된 서비스 엔진 NIC를 삭제합니다.