시스템 관리자는 프로비저닝 프로세스에서 Visual Basic 스크립트를 사용할 수 있도록 EPI(External Provisioning Infrastructure) 에이전트를 설치합니다.

다음 표에서는 프로비저닝 프로세스에서 Visual Basic 스크립트를 사용할 수 있도록 EPI 에이전트를 설치할 때 적용되는 요구 사항을 설명합니다.

표 1. 가상 스크립팅용 EPI 에이전트

요구 사항

설명

자격 증명

에이전트 실행에 사용될 자격 증명에는 설치 호스트에 대한 관리 액세스 권한이 있어야 합니다.

Microsoft PowerShell

에이전트 설치 전에 Microsoft PowerShell을 설치 호스트에 설치해야 합니다. 필요한 버전은 설치 호스트의 운영 체제에 따라 다르며 해당 운영 체제와 함께 설치되어 있을 수 있습니다. 자세한 정보는 http://support.microsoft.com을 참조하십시오.

MS PowerShell 실행 정책

MS PowerShell 실행 정책을 RemoteSigned 또는 Unrestricted로 설정해야 합니다.

PowerShell 실행 정책에 대한 정보를 보려면 Power-Shell 명령 프롬프트에서 다음 명령 중 하나를 실행하십시오.

help about_signing
help	Set-ExecutionPolicy