vRealize Business for Cloud를 사용하여 추적하고 분석하려는 AWS 계정을 추가할 수 없습니다.

문제

관리 탭에서 AWS 계정을 추가하려고 하면 AWS 데이터 수집 오류가 시스템 상태에 표시됩니다. 오류에 대한 자세한 내용은 itfm-server.log 파일을 검토하십시오.

원인

이 문제가 발생하는 이유는 다음 중 하나일 수 있습니다.
  • 계정을 추가할 때 지불 계정이 기본 계정으로 표시되지 않았습니다.
  • AWS CSV 파일이 너무 커서 vRealize Business for Cloud 가상 장치의 사용 가능한 스토리지를 초과합니다.
  • 지불 계정에 대해 세부 청구 보고서를 사용하도록 설정하지 않았습니다.
  • 계정 ID에 특수 문자 또는 알파벳이 포함되어 있거나 계정 ID의 길이가 12자를 넘습니다.
  • S3 버킷에서 청구 보고서를 사용할 수 없습니다.
  • 계정을 추가할 권한이 없습니다.

해결책

  • 이 문제를 해결하려면 다음 해결 방법 중에서 해당하는 단계를 수행합니다.
    • 계정을 추가하는 동안 지불 계정이 기본 계정으로 선택되었는지 확인합니다.
    • 지불 계정에 대해 세부 청구 옵션을 사용하도록 설정합니다.
    • 계정 ID에 특수 문자가 포함되지 않았는지 확인합니다.
    • S3 버킷에 하나 이상의 청구 보고서가 있고 다음 이름 지정 규칙을 따르는지 확인합니다. 123456789012-aws-billing-detailed-line-items-with-resources-and-tags-yyyy-mm.csv.zip. 여기서 123456789012는 계정 ID이고 yyyy는 연도이며 mm은 월입니다.
    • 지불 계정의 경우 AWS 사용자에게 s3:Get*, s3:List*, ec2:Describe* 등의 필요한 권한이 있는지 확인합니다.

      비지불 계정의 경우 AWS 사용자에게 ec2:Describe* 권한이 있는지 확인합니다.