vRealize Business for Cloud에 대규모 퍼블릭 클라우드 청구서에 대한 스토리지가 부족하다고 보고됩니다.

문제

AWS 또는 Azure 청구서의 압축을 푼 파일 크기가 크면, 가상 장치에 스토리지가 부족하여 청구서를 저장하지 못합니다.

원인

이 문제는 AWS 또는 Azure 청구서의 압축을 푼 파일 크기가 큰 경우에 발생합니다. 하드 디스크 공간이 부족하면 데이터 수집 프로세스 및 스토리지 액세스가 필요한 기타 프로세스에 영향을 미칩니다.

해결책

  1. vRealize Business for Cloud 장치를 종료합니다.
  2. vRealize Business for Cloud에 새 하드 디스크를 추가합니다.
  3. 가상 장치의 전원을 켭니다.
  4. SSL(Secure Sockets Layer)을 사용하여 가상 장치에 연결합니다.
  5. 셸 클라이언트에서 모든 디스크를 나열하고 새로 추가된 디스크의 디바이스 ID를 확인하려면 fdisk-lu를 실행합니다.
    참고:

    기본적으로 새 디스크에 대한 디바이스 ID는 /dev/sdb입니다.

  6. 새 디스크에 대한 디스크 유틸리티에 액세스하고 fdisk /dev/sdb 명령을 실행합니다.
    1. 새 파티션의 경우 n을 누른 다음 Enter 키를 누릅니다.
    2. 기본 파티션의 경우 p를 누른 다음 Enter 키를 누릅니다.
    3. 파티션 번호로 1을 누릅니다.
    4. 기본 시작 블록과 기본 끝 블록을 수락합니다(시작과 끝에 대해 Enter 키를 두 번 눌러서 기본값 사용.)
    5. w를 눌러서 파티션 테이블을 디스크에 기록합니다.
    6. 새 디스크에 파티션을 만듭니다.
  7. 새 디스크에 ext3 파일 시스템을 만들려면 mkfs-t ext3 /dev/sdb1을 실행합니다.
  8. AWS 또는 Azure의 청구서 크기가 크면 mount /dev/sdb1 /usr/local/tomcat/itbm-data-collector/temp/를 실행하여 데이터 수집기를 새 디스크의 임시 위치에 마운트합니다.
  9. mount -l을 실행합니다.

    이 명령은 새 파티션이 제대로 마운트되었는지 여부를 확인합니다. 출력에 /dev/sdb1 on /usr/local/tomcat/itbm-data-collector/temp type ext3 (rw,relatime,data=ordered)가 포함되었는지 여부를 확인합니다.

  10. vi를 사용하여 파일을 열려면 vi /etc/fstab를 실행합니다.
  11. /dev/sdb1 /usr/local/tomcat/itbm-data-collector/temp ext3 defaults 1 1을 추가합니다.

    이 단계는 가상 장치를 다시 시작해도 디스크가 마운트 해제되지 않도록 합니다.

해결책

vRealize Business for Cloud 가상 장치의 크기가 증가되었습니다.