vRealize Business for CloudvRealize Automation에 등록한 후 오류 메시지가 표시됩니다.

문제

vRealize Business for CloudvRealize Automation에 등록한 후 관리 > 비즈니스 관리로 이동하면 java.net.NoRouteToHostException: 호스트할 경로가 없음 오류 메시지가 표시됩니다.

원인

이 문제는 vRealize Business for CloudvRealize Automation에 등록한 후 vRealize Business for Cloud 가상 장치의 IP 주소가 변경된 경우에 발생합니다.

해결책

SSL 키 저장소 재생성에 대한 자세한 내용은 설치 가이드의 vRealize Business for Cloud의 SSL 인증서 변경 또는 바꾸기 섹션을 참조하십시오.

vRealize Business for Cloud를 등록하는 방법에 대한 자세한 내용은 설치 가이드의 vRealize Business for CloudvRealize Automation에 등록 섹션을 참조하십시오.

절차

  1. vRealize Business for Cloud의 등록을 취소합니다.
    1. vRealize Business for Cloud 웹 콘솔(https://vRealize_Business_for_Cloud_IP_address:5480)에 로그인합니다.
    2. 등록된 설정에 따라 해당 단계를 수행합니다.

      옵션

      절차

      vRealize Automation에 등록된 경우

      1. 모든 vRealize Automation 보고서를 다운로드합니다. 자세한 내용은 https://kb.vmware.com/s/article/2151835 의 내용을 참조하십시오.

      2. 등록 탭에서 vRealize Automation을 클릭합니다.

      3. 이미 등록된 vRealize Automation 서버의 세부 정보를 입력합니다.

      4. 등록 취소를 클릭합니다.

      모든 매개 변수가 올바른 경우 vRealize Automation 서버에 등록 취소됨 메시지가 나타납니다.

      VMware Identity Manager에 등록된 경우

      1. 등록 탭에서 vIDM을 클릭합니다.

      2. 이미 등록된 VMware Identity Manager 가상 장치의 세부 정보를 입력합니다.

      3. 등록 취소를 클릭합니다.

      모든 매개 변수가 올바른 경우 vIDM에 등록 취소됨 메시지가 나타납니다.

  2. 다음 단계 중 하나를 수행합니다.
    • vRealize Business for Cloud 가상 장치를 환경에서 제거하고 정적 IP 및 정규화된 도메인 이름을 사용하여 vRealize Business for Cloud의 새 인스턴스를 배포합니다.

    • SSL 키 저장소 파일(ssl.keystore)을 다시 생성합니다.

  3. vRealize Business for CloudvRealize Automation에 등록합니다.