RabbitMQ 플러그인을 모니터링하는 동안 오류가 표시될 수 있습니다.

문제

RabbitMQ 플러그인을 모니터링하는 동안 Telegraf 버전이 1.19인 vRealize Operations Cloud로 업그레이드하면 오류가 발생할 수 있습니다. 다음 메시지가 표시됩니다.

getting "/api/federation-links" failed: 404 Not Found

원인

RabbitMQ 설정에서 페더레이션 플러그인이 사용되도록 설정되지 않았습니다.

해결책

  • RabbitMQ VM에서 다음 명령을 실행하여 RabbitMQ 설정에서 페더레이션 플러그인을 사용하도록 설정합니다.
    rabbitmq-plugins enable rabbitmq_federation
    
    rabbitmq-plugins enable rabbitmq_federation_management