vRealize Orchestrator Appliance 7.4 | 2018년 4월 12일 | 8074344 빌드

이 릴리스 정보의 추가 및 업데이트 사항을 자주 확인하십시오.

릴리스 정보에 포함된 내용

릴리스 정보에는 다음과 같은 항목이 포함됩니다.

vRealize Orchestrator 7.4의 새로운 기능

vRealize Orchestrator 7.4은 여러 가지 개선 사항 및 버그 수정을 제공하고 새로운 옵션이 포함된 자동화된 구성을 확장합니다.

  • vRealize Orchestrator의 다중 테넌시
    • 컨텐츠 항목 및 실행이 완전히 분리되었습니다(다중 테넌시는 기본적으로 비활성화됨).
    • 테넌트 용으로 전용 vRealize Orchestrator 인스턴스를 배포할 필요가 감소되었습니다.
  • 웹 기반 Clarity UI 업데이트
    • 워크플로 실행과 메트릭이 포함되어, 워크플로 실행을 모니터링 및 문제 해결하는 새로운 모니터링 클라이언트 대시보드입니다. 워크플로의 실행 세부 정보를 볼 수 있는 기능이 추가되었습니다.
    • 새로운 모니터링 클라이언트에서 역할 관리에 바로 액세스할 수 있습니다.
    • 로그 보기가 중앙 집중식으로 제공됩니다.

기능 및 지원 공지사항

  • 멀티 테넌시 및 역할 관리는 vRealize 인증이 구성된 경우에만 사용할 수 있습니다.
  • 다음 기능은 EOL에 도달했으며 더 이상 vRealize Orchestrator에서 사용할 수 없고 지원되지 않습니다.
    • LDAP 인증

  • 다음 기능은 vRealize Orchestrator에서 더 이상 사용되지 않고 향후 릴리스에서 제거될 예정입니다.
    • 외부 데이터베이스 서버로서 Microsoft SQL 서버 및 Oracle 데이터베이스를 지원합니다.
    • SNMPv3를 지원합니다.
  • vCenter SSO(Single Sign-On) 레거시 인증 모드가 vSphere 인증 방법으로 대체되었습니다.
  • vRealize Automation 플러그인의 다음 워크플로는 더 이상 사용되지 않고 vRealize Automation 플러그인 7.4에 사용할 수 없습니다.
    • 관리 끝점 생성
    • 관리 끝점 삭제
    • 연결 자격 증명 삭제
    • 연결 자격 증명 생성

VMware vRealize Orchestrator Appliance 7.4 배포

VMware vRealize Orchestrator 7.4는 미리 구성된 가상 장치로 사용할 수 있습니다.

Orchestrator Appliance는 OVA 파일로 배포됩니다. Novell SUSE Linux Enterprise Server 및 PostgreSQL이 사전 설치되고 구성되어 있으며 vCenter Server 5.5 이상과 함께 배포할 수 있습니다.

Orchestrator Appliance는 빠르고 사용법이 쉬우며, 경제적인 방식으로 vRealize Automation, vCenter Server를 포함한 VMware Cloud 스택을 사용 중인 IT 프로세스 및 환경에 통합할 수 있습니다.

vRealize Orchestrator 7.4로 업그레이드

Orchestrator Appliance 배포 및 사용에 대한 지침은 VMware vRealize Orchestrator 업그레이드 및 마이그레이션을 참조하십시오.

참고: vRealize Orchestrator Appliance 버전 5.5.x에서 7.4으로의 업그레이드는 지원되지 않습니다. vRealize Orchestrator Appliance 5.5.x에서 6.0.x로 먼저 업그레이드해야 합니다.

중요: 보안상의 이유로 Orchestrator Appliance의 루트 계정 암호가 만료되는 기간은 365일로 되어 있습니다. 계정의 암호 만료 기간을 늘리려면 루트 계정으로 Orchestrator Appliance에 로그인한 후 다음 명령을 실행합니다.

passwd -x number_of_days name_of_account

Orchestrator Appliance 루트 암호를 영구적으로 사용하려면 다음 명령을 실행합니다.

passwd -x 99999 root

vRealize Orchestrator 7.4와 함께 설치되는 플러그인

vRealize Orchestrator 7.4는 기본적으로 다음 플러그인과 함께 설치됩니다.

  • vRealize Automation Center Infrastructure Administration 플러그인 7.4.0
  • vRealize Automation 플러그인 7.4.0
  • vRealize Orchestrator vCenter Server 플러그인 6.5.0
  • vRealize Orchestrator 메일 플러그인 7.0.1
  • vRealize Orchestrator SQL 플러그인 1.1.4
  • vRealize Orchestrator SSH 플러그인 7.1.0
  • vRealize Orchestrator SOAP 플러그인 2.0.0
  • vRealize Orchestrator HTTP-REST 플러그인 2.2.2
  • Microsoft Active Directory용 vRealize Orchestrator 플러그인 3.0.7
  • vRealize Orchestrator AMQP 플러그인 1.0.4
  • vRealize Orchestrator SNMP 플러그인 1.0.3
  • vRealize Orchestrator PowerShell 플러그인 1.0.13
  • vRealize Orchestrator Multi-Node 플러그인 7.4.0
  • vRealize Orchestrator 동적 유형 1.3.0
  • vRealize Orchestrator vCloud Suite API(vAPI) 플러그인 7.4.0
  • vRealize Orchestrator 플러그인 for vRealize Automation 7.4.0

국제화 지원

vRealize Orchestrator 7.4는 제어 센터에 대해 다국어 지원을 제공하며 Orchestrator 클라이언트에 대해 국제화 레벨 1을 지원합니다.

피드백 제공 방법

적극적으로 피드백을 보내주시면 감사드리겠습니다. 다음 방법 중 하나를 통해 피드백을 제공할 수 있습니다.

  • 지원 요청(SR)
  • Orchestrator 토론 포럼

지원 요청(SR)

지원 요청(SR)에 해당하는 모든 문제를 제출해 주십시오. 이러한 문제를 다른 방법으로 VMware에 보고한 경우에도 마찬가지입니다.

https://www.vmware.com/support/services/beta에서 고객이 제출한 지원 요청(SR)을 VMware 지원에서 처리하는 과정 및 지원 요청(SR)을 제출하는 방법을 알 수 있습니다.

지원 요청(SR)에 로그 파일을 포함시킵니다. Orchestrator에서 로그 파일 및 구성을 수집하는 다음 단계 수행:

  1. https://orchestrator_server_ip_address:8283/vco-controlcenter에서 제어 센터로 이동합니다.
  2. 관리자로 로그인합니다.
  3. 로그 내보내기를 클릭합니다.
  4. 로그 내보내기를 클릭합니다.
  5. 생성된 ZIP 파일을 저장합니다.
  6. 저장한 ZIP 파일을 VMware 지원에 업로드합니다.

이전 릴리스의 vRealize Orchestrator

이전 릴리스의 vRealize Orchestrator 기능 및 문제가 각 릴리스에 해당하는 릴리스 정보에 설명되어 있습니다. 이전 릴리스의 vRealize Orchestrator 릴리스 정보를 검토하려면 다음 링크 중 하나를 클릭합니다.

해결된 문제

  • Orchestrator 서버가 다시 시작되면 SOAP 작업을 시작하는 워크플로가 실패함

    SOAP 작업을 시작하는 워크플로를 실행한 후 Orchestrator 서버가 다시 시작되면 워크플로가 실패하고 다음과 유사한 오류 메시지가 나타납니다. Workflow:Invoke a SOAP operation / Prepare Parameters (item0) : ch.dunes.model.type.ConvertorException: Cannot convert to object , reason : Unable to perform operation 'find('Operation', '37c85322-ad52-45eb-84e3-ac91ad155dc3:Feedback')' on plugin 'SOAP' reason : 'Trying to put already available object'

  • vRealize Orchestrator에서 vSphere 인증을 구성하는 중에 Error 400! 오류가 발생함

    vRealize Orchestrator에서 vSphere 인증을 구성할 때 다음과 유사한 오류가 발생합니다. Error 400!Exception occurred. Details: Could not read document:
    Unexpected token (FIELD_NAME), expected END_OBJECT: expected closing END_OBJECT after type information and deserialized value at [Source: java.io.PushbackInputStream@16ebe97d; line: 1, column: 445]; nested exception is com.fasterxml.jackson.databind.JsonMappingException: Unexpected token (FIELD_NAME), expected END_OBJECT: expected closing END_OBJECT after type information and deserialized value at [Source: java.io.PushbackInputStream@16ebe97d; line: 1, column: 445]

  • 구성 요소에 보존된 값을 업데이트하는 중에 오류가 발생함

    Java 클라이언트에서 구성 요소에 보존된 값을 업데이트하는 경우 다음과 같은 오류가 발생합니다. java.lang.IllegalArgumentException: Comparison method violates its general contract!

  • 제어 센터에 로그인할 때 vSphere 인증을 사용하면 시간 초과 오류가 발생함

    vSphere를 사용하여 Orchestrator가 인증되며 사용자가 다수의 사용자 그룹에 속하는 경우 제어 센터에 로그인할 때 시간 초과 오류가 발생합니다.

  • 중첩된 워크플로가 실패하고 다음과 같은 오류 메시지가 나타남. java.lang.IllegalArgumentException: [class/interface] is not visible from class loader

    중첩된 워크플로가 실패하고 다음과 같은 오류 메시지가 나타납니다. java.lang.IllegalArgumentException: [class/interface] is not visible from class loader

  • Java 클라이언트의 워크플로에서 특성 복합 유형을 정의한 후 해당 복합 유형을 편집할 수 없음

    Java 클라이언트의 워크플로에서 특성 복합 유형을 정의한 후 해당 복합 유형을 편집할 수 없습니다.

  • 워크플로 실행, 정책 또는 작업이 실패하고 다음과 같은 오류 메시지가 나타남. Unable to authenticate with OAuthToken

    워크플로 실행, 정책 또는 작업이 실패하고 다음과 같은 오류 메시지가 나타납니다. Unable to authenticate with OAuthToken

  • 사용자, 그룹 또는 테넌트로 인증할 때 대소문자를 틀리게 사용하면 제어 센터에 로그인하지 못할 수 있음

    사용자, 그룹 또는 테넌트로 인증할 때 대소문자를 틀리게 사용하면 제어 센터에 로그인하지 못할 수 있습니다.

  • 패키지 내보내기가 구성 요소에서 SecureString 값을 보존하지 않음

    이전에 내보낸 패키지를 가져올 때 구성 요소의 SecureString 값이 비어 있습니다. 이를 사용하는 워크플로가 실패합니다.

  • 부울 입력 매개 변수를 사용하는 사용자 상호 작용을 No(아니요)로 설정할 수 없음

    워크플로 특성으로서 기본값이 true로 설정되어 있고 데코레이터가 없는 부울 입력 매개 변수를 사용하는 사용자 상호 작용을 No(아니요)로 설정할 수 없습니다.

  • 클러스터 동기화 후 동적 유형 정의가 손실됨

    클러스터 동기화 후 일부 노드에서 구성된 유형 및 관계가 누락될 수 있습니다.

  • CMD를 실행할 때 최대 라인 길이 제한 때문에 PowerShell 플러그인이 Windows Server 2012에 연결되지 않음

    CMD를 실행할 때 최대 라인 길이 제한 때문에 PowerShell 플러그인이 Windows Server 2012에 연결되지 않습니다.

  • vSphere 인벤토리 폴더의 하위 집합에 대한 사용 권한이 있는 경우 vCenter Server 플러그인 인벤토리를 검색할 때 오류가 발생함

    vSphere 인벤토리 폴더의 하위 집합에 대한 사용 권한이 있는 경우 vCenter Server 인벤토리를 검색할 수 없습니다.

  • 워크플로 요소 간에 VirtualEthernetCard 개체를 전달하는 경우 워크플로 실행이 실패할 수 있음

    이 문제는 둘 이상의 사용자가 공유 세션 모드에서 등록된 vCenter Server 인스턴스에 대해 동일한 워크플로를 동시에 실행할 때 발견됩니다.

  • vCenter Server 플러그인의 '독립 디스크 변환' 워크플로가 디스크를 종속으로 변환하지 않음

    vCenter Server 플러그인의 독립 디스크 변환 워크플로가 디스크를 종속으로 변환하지 않습니다.

  • vAPI 클라이언트가 명시적으로 닫혀 있지 않은 경우 모니터링 스레드가 누출됨

    vAPI 클라이언트가 명시적으로 닫혀 있지 않은 경우 모니터링 스레드가 누출됩니다. vAPI 클라이언트를 사용하는 올바른 방식을 표시하도록 예제 워크플로가 업데이트되었습니다.

  • 다수의 메시지를 처리해야 하는 경우 AMQP 플러그인이 실패함

    AMQP 플러그인이 다수의 메시지를 즉시 처리할 수 없어 실패합니다. 이 문제는 대기열이 너무 커지고 플러그인이 실패하려 할 때 메시지를 삭제함으로써 해결되었습니다.

알려진 문제

알려진 문제는 다음과 같이 분류됩니다.

설치 문제
  • Orchestrator 서비스가 백업 및 복원 절차 후 복구되지 않음.
    Orchestrator를 백업 및 복원할 때 서버는 vCenter Orchestrator 서버에 연결할 수 없습니다 오류로 인해 vRealize Automation에서 액세스할 수 없습니다. 이로 인해 Orchestrator가 시작됨 상태이지만 시작할 수 없고, 작업 및 정책이 누락되고, 워크플로를 다시 실행해야 합니다.

    해결 방법: 누락된 예약된 작업 및 정책을 다시 만들고, 시작하지 않은 예약된 워크플로를 다시 실행하고, Orchestrator 서비스를 다시 시작합니다.

구성 문제
  • 인증 설정에서 아무 것도 변경하지 않고 구성 인증 제공자 페이지에서 변경 사항 저장 버튼을 클릭하면 더 이상 제어 센터에 액세스할 수 없습니다.
    제어 센터의 인증 제공자 구성 페이지에서 이미 구성된 인증 매개 변수를 변경하지 않고 재저장하는 경우 An error occurred during OAuth2 operation. Please contact your administrator to resolve the issue. { “error”: “invalid_request”, “error_description”: “Must provide a valid redirect uri.” } 오류 메시지가 표시되고 제어 센터에 더 이상 액세스할 수 없습니다.
  • 제어 센터에 플러그인을 설치하는 동안 오류 메시지가 표시됨.
    제어 센터의 Manage Plug-Ins 페이지에서 플러그인을 설치하면 다음이 나타납니다. Plug-in 'name_of_the_plug-in' (plug-in_file_name) is not compatible with the current platform version. Supported platform versions are ''. Clicking on the 'Install' button will install it anyway 오류 메시지. 이 오류 메시지를 무시하고 플러그인 설치를 계속 진행할 수 있습니다.
  • vRealize Orchestrator SQL 플러그인을 MySQL 데이터베이스에 연결할 수 없음.
    MySQL 데이터베이스에 대해 데이터베이스 추가 워크플로를 실행하면 The driver ‘com.mysql.jdbc.Driver’ for ‘MySQL’ database cannot be found! 오류 메시지와 함께 워크플로에 실패합니다.

    참고: MySQL 데이터베이스 지원이 vRealize Orchestrator 7.0에서 제거되었습니다.

    해결 방법: MySQL 데이터베이스 지원을 활성화하려면 Orchestrator 플랫폼에 MySQL용 JDBC 드라이버를 설치해야 합니다.

    1. MySQL용 최신 JDBC 드라이버를 http://dev.mysql.com/downloads/connector/j/에서 다운로드합니다.
    2. 다운로드한 아카이브의 압축을 풉니다.
    3. 압축 해제된 폴더에서 mysql-connector-java-x.x.x.jar 파일을 찾습니다. x.x.x는 현재 Subminor 버전입니다.
    4. mysql-connector-java-x.x.x.jar를 Orchestrator 서버의 /usr/lib/vco/app-server/lib 디렉토리로 복사합니다.
    5. mysql-connector-java-x.x.x.jar 파일의 소유권을 변경합니다.
    6. chown vco:vco mysql-connector-java-x.x.x.jar

    7. mysql-connector-java-x.x.x.jar의 권한을 변경합니다.
    8. chmod 644 mysql-connector-java-x.x.x.jar

    9. Orchestrator 서버 서비스를 재시작합니다.
    10. service vco-server restart

  • 인증 제공자 인증서가 변경되거나 다시 생성된 경우 Orchestrator 인증 구성이 무효화될 있습니다.
    제어 센터에서 인증 제공자로 구성된 vRealize Automation 또는 vSphere 인스턴스의 SSL 인증서가 변경되거나 다시 생성되면 Orchestrator 인증 구성이 무효화되고 Orchestrator 서버를 시작할 수 없습니다.

    해결 방법: 새 인증 제공자 인증서를 가져옵니다.

    1. 제어 센터에 관리자로 로그인합니다.
    2. 인증서를 클릭합니다.
    3. 신뢰할 수 있는 인증서에서 가져오기 탭을 클릭합니다.
    4. URL 또는 파일에서 SSL 인증서를 로드합니다.
    5. 가져오기를 클릭합니다.

  • SOAP 플러그인이 인증된 프록시 서버를 통해 연결되지 않습니다.
    Add a SOAP host 워크플로를 실행할 때 인증이 필요 없는 프록시 서버를 사용합니다.
  • Orchestrator 클라이언트가 Java 8 이전 버전에서 실행되지 않습니다.
    Orchestrator 클라이언트를 Java 8에서 실행해야 합니다.
  • SOAP 또는 REST 호스트에 연결하거나 인증서를 가져올 때 문제가 발생하는 경우 특정 버전의 SSL 또는 TLS를 사용해야 할 수 있습니다.
    이 문제에 대한 자세한 내용은 https://docs.oracle.com/javase/8/docs/technotes/guides/security/jsse/JSSERefGuide.html을 참조하십시오.

    해결 방법: 송신 HTTPS 연결을 위한 SSLv3 및 TLSv1 사용에 대한 자세한 내용은 vRealize Orchestrator 6.0.4 및 7.0.x에서 수동으로 송신 HTTPS 연결을 위한 TLSv1 사용(KB 2144318)을 참조하십시오.

  • vSphere Web Client의 vCenter Server 개체에 액세스하지 못함.
    액세스하려는 vCenter Server 인스턴스가 IP 주소로 Orchestrator에 등록된 경우 Orchestrator가 vSphere Web Client의 vCenter Server 개체에 액세스할 수 없습니다.

    해결 방법: 호스트 이름으로 vCenter Server 인스턴스를 등록합니다.

  • TNSNames를 사용하는 Oracle 데이터베이스 연결을 지원하지 않음.
    TNSNames를 사용하여 Oracle 데이터베이스에 연결할 수 없습니다. IP 주소 또는 DNS 이름을 사용하여 Oracle 데이터베이스에 연결할 수 있습니다.

    해결 방법: Oracle 11g 데이터베이스 인스턴스에 대한 RAC 및 TNS 구성 지원을 vRealize Orchestrator에 추가(KB 1022828)를 참조하십시오.

클라이언트 문제
  • 워크플로를 복제하면 버전 기록 복사가 아니요로 설정되어도 항상 원래 워크플로의 버전 기록을 복사함.
    복제 워크플로 단계에서 복제 중 버전 기록 복사에 대해 아니요 라디오 버튼을 선택해도 이벤트 기록을 원래 워크플로에서 복사된 워크플로로 전송합니다.
  • 입력 매개 변수의 OGNL 표현식이 입력 매개 변수가 업데이트될 때마다 실행됨
    입력 매개 변수가 2개 이상 입력 매개 변수에 바인딩된 OGNL 표현식을 포함하는 경우 모든 입력 매개 변수가 업데이트되면 OGNL 표현식이 한 번만 실행되는 대신 입력 매개 변수가 업데이트될 때마다 실행됩니다. OGNL 표현식에서 데이터 마이닝과 같이 리소스를 많이 소모하는 작업을 호출하면 프레젠테이션 실행 속도가 느려질 수 있습니다.
  • 특정 컨텍스트에서 ASCII가 아닌 문자를 처리할 때 문제 발생.
    입력 매개 변수에서 ASCII가 아닌 문자를 사용하면 다음 상황에서 잘못된 동작이 발생합니다.
    • 이름에 ASCII가 아닌 문자를 포함하는 파일이 있는 SSH 폴더에서 SCP put 또는 SCP get 워크플로를 실행하면 워크플로는 실행되지만 대상 시스템에서 결과 파일의 이름을 판독할 수 없습니다.
    • ASCII가 아닌 문자를 특성 이름에 삽입하면 문자가 표시되지 않습니다. 이 문제는 워크플로 특성 및 작업 특성으로 인해 발생합니다.
  • Orchestrator Appliance가 NAT(네트워크 주소 변환) 뒤에 있으면 Java WebStart를 통한 Orchestrator 클라이언트 사용을 지원하지 않음.
  • 이름에 공백이 있는 작업 모듈 내에 vRealize Orchestrator 작업은 vRealize Automation에 의해 사용자 지정 속성으로 인식되지 않습니다.

    Orchestrator 7.0 이전의 모든 버전에서 업그레이드한 후, 이름에 공백이 있는 작업 모듈은 7.x 이후 버전을 실행하는 vRealize Automation이 설치된 경우 더 이상 보이지 않습니다. 그 결과 이러한 모듈에 있는 작업은 vRealize Automation의 속성 정의에 연결할 수 없습니다.

    해결 방법: 작업 모듈의 이름에 공백이 없는지 확인합니다. vRealize Orchestrator를 업그레이드하기 전에 작업 모듈 이름에서 모든 공백을 밑줄(_) 또는 점(.)으로 교체합니다.

기타 문제
  • vRealize Orchestrator 6.x 가상 장치에서 구성을 내보내기 위해 마이그레이션 도구를 실행하는 경우 오류 메시지가 발생합니다.
    vRealize Orchestrator 6.x 가상 장치에서 vRealize Orchestrator 7.3으로 마이그레이션 하는 도중, 구성을 내보내기 위해 마이그레이션 도구를 대상에서 소스 Orchestrator 서버로 복사하고 vro-migrate.sh 스크립트를 실행하면 다음의 오류 메시지가 나타납니다.

    SLF4J: "org.slf4j.impl.StaticLoggerBinder" 클래스를 로드하지 못했습니다.
    SLF4J: NOP(작업 없음) 로거 구현이 기본값으로 설정됩니다.
    SLF4J: 자세한 내용은 http://www.slf4j.org/codes.html#StaticLoggerBinder를 참조하십시오.

    해결 방법: 이 메시지는 무시해도 됩니다. orchestrator-config-export-orchestrator_ip_address-date_hour.zip 아카이브가 /var/lib/vco 폴더에서 생성되었는지 확인하고 마이그레이션을 계속 수행합니다.

  • 클러스터에 하나 이상의 Orchestrator 인스턴스가 있으면 워크플로가 실행된 Orchestrator 노드에만 워크플로 토큰이 표시됨.
  • vCenter Server 플러그인의 Storage VSAN 워크플로가 SSD(Solid-State Drive) 디스크를 ESXi 호스트에 추가하는 것을 지원하지 않음.
    Add disks to disk groupRemove disks from disk groups 워크플로가 SSD 디스크를 용량 디스크로 ESXi 호스트에 추가하는 것을 지원하지 않음.
  • vCenter Server 플러그인이 정책을 지원하지 않음.
    vRealize Orchestrator용 vCenter Server 플러그인이 관리형 vCenter Server 인스턴스에서 발생된 이벤트를 모니터링하기 위한 정책을 사용하는 것을 지원하지 않습니다.
  • 람다 표현식이 포함된 확장자 메소드를 사용하는 경우 맞춤형 모델 중심 플러그인의 컴파일링이 실패함.
    플러그인을 생성하기 위해 모델 중심을 사용하며 특정 확장자에 확장자 메소드를 추가할 때, 확장자 메소드에 람다 표현식이 포함된 경우 플러그인이 컴파일링을 수행하지 않습니다. 플러그인 컴파일이 다음과 유사한 오류 메시지와 함께 실패합니다. Caused by: java.lang.ArrayIndexOutOfBoundsException: 52789.

    해결 방법: 확장자 메소드의 본문에서 람다 표현식을 사용하지 마십시오.

  • REST 호스트 인스턴스가 Swagger 사양을 사용하여 생성되면 RESTOperation ID가 올바르게 초기화되지 않음.
    HTTP-REST 플러그인에서 REST 호스트 인스턴스가 Swagger 사양에 의해 생성되면 RESTOperation ID가 올바르게 초기화되지 않고 REST 호스트 개체의 getOperation이 작동하지 않습니다.
  • SOAP 플러그인이 SOAP 호스트를 사용한 상호 인증을 지원하지 않음.
    사용 가능한 인증 메커니즘은 단방향 인증만 지원합니다.
  • SSH 플러그인을 Cisco Adaptive Security Appliance(ASA) 방화벽에 연결할 수 없음.
    vRealize Orchestrator 7.1용 SSH 플러그인은 Cisco Adaptive Security Appliance(ASA) 방화벽에 대한 연결을 지원하지 않습니다.
  • 사용자별 세션을 선택한 경우 vCenter Server 인벤토리에 대한 액세스를 제한하면 오류가 발생할 수 있음.
    vCenter Server 인스턴스를 Orchestrator에 추가할 때 사용자별 세션 옵션을 선택한 경우 인벤토리 개체에 대한 액세스가 제한된 사용자가 vCenter Server 인벤토리에 액세스하려고 하면 오류가 발생할 수 있습니다.
  • Orchestrator 6.0.2 이하 버전에서 업그레이드한 후 vCenter Server 플러그인에 유효한 자격 증명이 없음.
    Orchestrator 6.0.3 이전 버전에서 업그레이드한 경우 vCenter Server 플러그인에 유효한 자격 증명이 없습니다.

    해결 방법: Orchestrator를 업그레이드한 후 vCenter Server 인스턴스를 업데이트하고 사용자 암호를 구성합니다.

  • 디스크를 씬 프로비저닝으로 변환하는 워크플로가 스냅샷이 있는 가상 시스템을 올바르게 처리하지 못하고 씩 프로비저닝 디스크가 변환되지 않음.
    디스크를 씬 프로비저닝으로 변환하는 워크플로를 완료하면 스냅샷이 있는 가상 시스템의 씩 프로비저닝 디스크가 씬 프로비저닝으로 변환되었음을 보고하지만 실제로는 변환되지 않습니다.

    해결 방법: 워크플로에 스냅샷이 있는 가상 시스템을 포함하지 마십시오.

  • 어레이 유형의 vCenter Server 데이터 개체 속성에 값을 추가할 수 없음.
    Orchestrator가 스크립트를 실행하면 vCenter Server 플러그인이 JavaScript 어레이를 고정된 크기의 Java 어레이로 변환합니다. 따라서 어레이를 속성 값으로 갖는 vCenter Server 데이터 개체에 새 값을 추가할 수 없습니다. 미리 채워진 어레이로 전달하여 개체를 인스턴스화하면 어레이를 속성으로 갖는 개체를 생성할 수 있습니다. 그러나, 개체를 인스턴스화한 후에는 값을 어레이에 추가할 수 없습니다.

    예를 들어, 다음 코드는 작동하지 않습니다.

    var spec = new VcVirtualMachineConfigSpec();
    spec.deviceChange = [];
    spec.deviceChange[0] = new VcVirtualDeviceConfigSpec();
    System.log(spec.deviceChange[0]);

    위 코드에서 Orchestrator는 빈 spec.deviceChange JavaScript 어레이를 고정 크기의 Java 어레이 VirtualDeviceConfigSpec[]setDeviceChange()를 호출하기 전에 변환합니다. spec.deviceChange[0] = new VcVirtualDeviceConfigSpec()을 호출하면, Orchestrator는 getDeviceChange()를 호출하고 어레이는 고정된 비어 있는 Java 어레이 상태로 유지됩니다. spec.deviceChange.add()를 호출하면 같은 동작이 발생합니다.

    해결 방법: 어레이를 지역 변수로 선언:

    var spec = new VcVirtualMachineConfigSpec();
    var deviceSpec = [];
    deviceSpec[0] = new VcVirtualDeviceConfigSpec();
    spec.deviceChange = deviceSpec;
    System.log(spec.deviceChange[0]);

  • 두 워크플로 요소 사이에 VcSnapshotInfo 개체를 Any 유형 특성으로든 전달하면 직렬화 과정에서 예외 발생

    vCenter Server 플러그인에서 VcSnapshotInfo 개체나 VcSnapshotInfo 개체의 어레이를 Any 유형 특성으로 두 워크플로 요소 사이에 전달하면 Can not set long field com.codahale.metrics. 오류 메시지와 함께 직렬화 실패가 트리거됩니다.

    해결 방법: 워크플로 객체 간에 VcSnapshotInfo 객체 또는 VcSnapshotInfo 개체의 어레이 전달을 생략하도록 워크플로를 수정합니다.

설명서 및 도움말

    다음의 항목 또는 수정 사항은 이 릴리스에 대한 설명서에 포함되지 못했습니다.

    • 외부 Orchestrator 서버를 vRealize Automation에 포함된 Orchestrator 인스턴스로 마이그레이션할 때 vRealize Automation을 이전 버전에서 마이그레이션하는 경우라면 vRealize Automation Appliance에서 Orchestrator 서버 서비스 및 제어 센터 서비스를 시작하기 전에 포함된 Orchestrator 인스턴스의 데이터베이스에서 신뢰할 수 있는 인증서를 삭제해야 합니다.
      설명서 주제 외부 vRealize Orchestrator 7.x를 vRealize Automation 7.3으로 마이그레이션에서 4단계의 설명대로 마이그레이션한 후 포함된 Orchestrator의 데이터베이스에서 신뢰할 수 있는 인증서를 삭제해야 합니다.

      sudo -u postgres -i -- /opt/vmware/vpostgres/current/bin/psql vcac -c “DELETE FROM vmo_keystore WHERE id=’cakeystore-id’;”

    • vRealize Orchestrator에서 플러그인 제거 과정이 설명서 주제 플러그인 제거에 설명된 대로 진행되지 않습니다.

      해결 방법: 아래 단계를 실행하여 플러그인을 제거합니다. 클러스터에 Orchestrator 노드가 여러 개인 경우 모든 노드에서 이 단계를 실행합니다.

      1. SSH에서 루트로 Orchestrator Appliance에 로그인합니다.
      2. Orchestrator 서버 서비스 및 제어 센터 서비스를 중지합니다.

        service vco-server stop && service vco-configurator stop

      3. 텍스트 편집기로 /etc/vco/app-server/plugins/_VSOPluginInstallationVersion.xml 파일을 열고 제거하려는 플러그인에 해당하는 코드 줄을 삭제합니다.
      4. /var/lib/vco/app-server/plugins 디렉토리에서 제거하려는 플러그인이 포함된 .dar 아카이브를 삭제합니다.
      5. Orchestrator 데이터베이스의 VMO_VroConfiguration 테이블에서 모든 레코드를 삭제합니다.

        예를 들어, Microsoft SQL Server를 사용하는 경우 삭제 구문은 DELETE FROM [database_name].[dbo].[VMO_VroConfiguration]입니다.

      6. Orchestrator 서버 서비스 및 제어 센터 서비스를 시작합니다.

        service vco-server start && service vco-configurator start

      7. 설명서 주제 플러그인 제거5단계에 설명된 대로 플러그인과 관련된 패키지 및 폴더를 삭제합니다.
    check-circle-line exclamation-circle-line close-line
    Scroll to top icon