Voor de ICA-eigenschappen in VMware Identity Manager moet de coderingseigenschap zijn ingesteld op hetzelfde coderingsniveau als het niveau dat op de XenApp-servers in de farm is geconfigureerd, anders krijgen gebruikers geen toegang tot hun gepubliceerde Citrix-applicaties of -desktops.
Probleem
Wanneer een gebruiker verbinding maakt met een gepubliceerde Citrix-bron van
VMware Identity Manager, wordt de volgende foutmelding weergegeven.
U beschikt niet over het juiste coderingsniveau voor toegang tot deze sessie
Oorzaak
Voor VMware Identity Manager zijn geen coderingsniveaus ingesteld. Als het coderingsniveau op de XenApp-server op een hogere waarde is ingesteld dan de standaardinstelling die in de Citrix Receiver wordt gebruikt, zien gebruikers deze fout.
U moet een hoger coderingsniveau in VMware Identity Manager instellen.
Oplossing
- Meld u aan bij de VMware Identity Manager-console.
- Klik op het tabblad Instellingen. en klik vervolgens op
- Klik in het linkerdeelvenster, afhankelijk van uw implementatie, op Citrix XenApp of Citrix XenDesktop.
- Maak de volgende wijzigingen in de secties ICA-configuratie en NetScaler ICA-configuratie.
- Stel het coderingsniveau in het tekstvak ICA-clienteigenschappen in met de volgende eigenschap:
EncryptionLevelSession=EncRC5-128In dit voorbeeld wordt het coderingsniveau ingesteld op 128, maar u moet dit wijzigen in het niveau dat op de XenApp-servers is geconfigureerd.
- Stel het coderingsniveau in het tekstvak ICA-starteigenschappen in door de volgende eigenschap in te voeren of te bewerken:
[EncRC5-128]
DriverNameWin16=pdc128w.dll
DriverNameWin32=pdc128n.dll
In dit voorbeeld wordt het coderingsniveau ingesteld op 128, maar u moet dit wijzigen in het niveau dat op de XenApp-servers is geconfigureerd.
- Stel het coderingsniveau in het tekstvak ICA-clienteigenschappen in met de volgende eigenschap: