Gebruikers kunnen geen applicaties starten vanaf de Workspace ONE Hub-portal of de verkeerde verificatiemethode is toegepast in een omgeving met load balancing.
Probleem
- Gebruikers kunnen geen applicaties starten vanaf de Workspace ONE-portal nadat ze zich hebben aangemeld.
- De verkeerde verificatiemethode wordt aan gebruikers aangeboden voor verificatie.
Oorzaak
Deze problemen kunnen zich voordoen als het toegangsbeleid onjuist is vastgelegd. Het IP-adres van de client bepaalt welk toegangsbeleid wordt toegepast tijdens aanmelding en tijdens het starten van een applicatie. In een omgeving met gelijkmatige taakverdeling gebruikt Workspace ONE Access de kop X-Forwarded-For om het IP-adres van de client te bepalen. In sommige situaties kan een fout optreden.
Oplossing
Stel de eigenschap service.numberOfLoadBalancers
in het bestand runtime-config.properties in voor elk van de knooppunten in uw Workspace ONE Access-cluster. De eigenschap bepaalt het aantal load balancers die het hoofd bieden aan de Workspace ONE Access-instanties.
- Meld u aan bij de Workspace ONE Access-appliance.
- Bewerk het bestand /usr/local/horizon/conf/runtime-config.properties en voeg de volgende eigenschap toe:
service.numberOfLoadBalancers numberOfLBs
waarbij
numberOfLBs
het aantal load balancers is die het hoofd bieden aan de Workspace ONE Access-instanties. - Start de appliance van de werkruimte opnieuw.
service horizon-workspace restart