Als u VMware vRealize®-producten of VMware NSX-T™ met VMware Identity Manager™ 3.3.1 gebruikt, kunt u VMware Identity Manager upgraden naar versie 3.3.2.

Zie de Release notes voor VMware Identity Manager 3.3.2 voor meer informatie over de release van VMware Identity Manager 3.3.2.

Opmerking: U kunt VMware Identity Manager 3.3.2 ook volledig opnieuw installeren. Als u een nieuwe installatie van 3.3.2 wilt uitvoeren, raadpleegt u de 3.3-versie van VMware Identity Manager voor Linux installeren en configureren. Deze is ook van toepassing op 3.3.2.

Volg Multitenancy met tenant in hostnaam met vRealize Automation 8.1 inschakelen als u een VMware vRealize® Automation™-klant bent.

VMware Identity Manager-upgradetrajecten

Het volgende upgradetraject wordt ondersteund:

  • Van versie 3.3.1 rechtstreeks naar versie 3.3.2.

VMware Identity Manager Connector-upgradetrajecten

De volgende upgradetrajecten worden ondersteund:

  • Een upgrade van VMware Identity Manager Connector voor Linux van 3.3.1 naar 3.3.2.
  • Een upgrade van VMware Identity Manager Connector voor Windows van 3.3.1 naar 3.3.2 voor connectorinstanties die zijn geïnstalleerd met behulp van het VMware Identity Manager Connector-installatieprogramma.

Het volgende upgradetraject wordt niet ondersteund:

  • Een upgrade van VMware Identity Manager Connector voor Windows van 3.3.1 naar 3.3.2 voor connectorinstanties die zijn geïnstalleerd door VMware vRealize® Suite Lifecycle Manager™.

VMware-producten die kunnen worden geüpgraded naar VMware Identity Manager 3.3.2

  • vRealize-producten zoals VMware vRealize Automation™, VMware vRealize Suite Lifecycle Manager, VMware vRealize® Operations™, VMware vRealize® Business™ for Cloud , VMware vRealize® Log Insight en VMware vRealize® Network Insight™ voor verificatie en SSO.
    • vRealize-producten die worden geïmplementeerd en beheerd via vRealize Suite Lifecycle Manager, kunnen alleen gebruikmaken van VMware Identity Manager 3.3.1 of 3.3.2.
    • vRealize Suite Lifecycle Manager kan nu een geheel nieuwe installatie van VMware Identity Manager 3.3.1 of 3.3.2 of een upgrade van VMware Identity Manager 3.3.1 naar 3.3.2 verwerken.
  • NSX-T voor verificatie en SSO
    • NSX-T kan worden geïmplementeerd met VMware Identity Manager 3.3.1 of 3.3.2 of van een eerdere versie worden geüpgraded naar 3.3.2.

Internetverbinding

U kunt VMware Identity Manager online of offline upgraden.

De VMware Identity Manager-appliance gebruikt standaard de VMware-website voor de upgradeprocedure. Voor deze benadering heeft de appliance een internetverbinding nodig. Indien van toepassing, moet u ook de instellingen voor de proxyserver voor de appliance configureren.

Als uw virtual appliance geen verbinding met internet heeft, kunt u offline upgraden. Voor een offline-upgrade downloadt u het upgradepakket van My VMware. U gebruikt het script updateoffline.hzn om de upgrade uit te voeren.

Upgradescenario's

  • Wanneer u één VMware Identity Manager-appliance heeft geïmplementeerd, kunt u deze online of offline upgraden zoals is beschreven in VMware Identity Manager online upgraden of VMware Identity Manager offline upgraden.
    Opmerking: Houd er rekening mee dat alle services tijdens de upgrade worden gestopt. Daarom is het handig om uw upgrade goed te plannen.
  • Wanneer u meerdere virtual appliances van VMware Identity Manager in een cluster voor failover of hoge beschikbaarheid heeft geïmplementeerd, kunt u Een cluster bijwerken raadplegen.

Groottevereisten voor de hardware

De vereisten voor de aanpassing van de grootte van de hardware in de volgende tabel zijn specifiek voor VMware Identity Manager 3.3.2. Zie de 3.3-versie van de handleiding VMware Identity Manager voor Linux installeren en configureren voor een uitgebreidere lijst met vereisten voor de aanpassing van de grootte van de hardware. Deze zijn ook van toepassing zijn op 3.3.2.

Belangrijk:

Voor het beste resultaat voert u de volgende synchronisatieprocedures uit.

  • Omdat de initiële directorysynchronisatie een intensieve bewerking is die veel resources verbruikt, voert u de initiële directorysynchronisatie op één tenant tegelijk uit.
  • Wissel directorysynchronisaties op tenants af om het resourceverbruik voor het uitvoeren van directorysynchronisaties op twee of meer tenants tegelijk te vermijden.

U kunt de interne PostgreSQL-database of een externe Microsoft SQL-database gebruiken. Beide opties kunnen hoge beschikbaarheid bieden.

Om hoge beschikbaarheid te bereiken met de interne PostgreSQL-database, moet u gebruikmaken van vRealize Suite Lifecycle Manager. Zie de volgende tabel en de handleiding vRealize Suite Lifecycle Manager 8.1 installeren, upgraden en beheren.

Zie de 3.3-versie van de handleiding VMware Identity Manager voor Linux installeren en configureren voor een externe Microsoft SQL-databaseconfiguratie.

Directorysynchronisatie van gebruikers en groepen per tenant* VMware Identity Manager-appliance met interne PostgreSQL-database en ingesloten connector, op basis van knooppuntvereisten Externe Windows-gebaseerde connector, op basis van connectorinstantievereisten
Maximum:
  • 5000 gebruikers
  • 50 groepen
Eén knooppunt of een cluster met drie knooppunten:
  • 6 vCPU
  • 8 GB geheugen
  • 50 GB schijfopslag
  • 2 vCPU
  • 6 GB geheugen
  • 30 GB schijfopslag
Maximum:
  • 10.000 gebruikers
  • 100 groepen
Cluster met drie knooppunten:
  • 8 vCPU
  • 12 GB geheugen
  • 80 GB schijfopslag
  • 4 vCPU
  • 6 GB geheugen
  • 50 GB schijfopslag
Maximum:
  • 25.000 gebruikers
  • 250 groepen
Cluster met drie knooppunten:
  • 10 vCPU
  • 16 GB geheugen
  • 100 GB schijfopslag
  • 4 vCPU
  • 8 GB geheugen
  • 50 GB schijfopslag
Maximum:
  • 50.000 gebruikers
  • 500 groepen
Cluster met drie knooppunten:
  • 12 vCPU
  • 32 GB geheugen
  • 100 GB schijfopslag
  • 4 vCPU
  • 16 GB geheugen
  • 60 GB schijfopslag
Maximum:
  • 100.000 gebruikers
  • 1000 groepen
Cluster met drie knooppunten:
  • 14 vCPU
  • 48 GB RAM
  • 100 GB schijfopslag
  • 4 vCPU
  • 16 GB geheugen
  • 60 GB schijfopslag

*Als het aantal gebruikers of het aantal groepen voor een tenant het maximum overschrijdt, raadpleegt u de volgende rij.