Before you run the upgrade, review the prerequisites.

System Configuration Requirements

Verify the following system requirements before you begin an upgrade.

  • Verify that you are following a supported upgrade path. See the vRealize Automation release notes for a list of supported upgrade paths.

  • Verify that all appliances and servers that are part of your deployment meet the system requirements for the version you are upgrading to. See the vRealize Automation Support Matrix on the VMware Web site at https://www.vmware.com/support/pubs/vcac-pubs.html.

  • If you are using a vSphere SSO, verify that it is a supported version and at the correct patch level. See the Ondersteuningsmatrix voor vRealize Automation for information about supported versions

  • Consult the VMware Product Interoperability Matrix on the VMware Web site for information about compatibility with other VMware products.

General Prerequisites

Verify that the following prerequisites are finished before you begin an upgrade.

  • Your source installation is fully installed and configured.

  • Microsoft Distributed Transaction Coordinator (MSDTC) is enabled on all vRealize Automation and associated SQL servers. For instructions, see the VMware Knowledge Base article Various tasks fail after upgrading or migrating to VMware vCloud Automation Center (vCAC) 6.1.x (2089503) at http://kb.vmware.com/kb/2089503.

  • You have backups for vRealize Appliance configuration files in the following directories for each appliance.

    • /etc/vcac/

    • /etc/vco/

    • /etc/apache2/

    • /etc/rabitmq/

  • You have backups for all databases.

  • You have backups for any files you have customized, such as DataCenterLocations.xml.

  • You have a snapshot of your virtual appliances and IaaS servers.

  • You perform the upgrade at a time when the system is not in heavy use.

  • You have followed the instructions in vCloud Automation Center-services afsluiten op de IaaS Windows-server.

Order of Upgrade for Integrations

Review the following table for information about the order of upgrade for other VMware components integrated with your vRealize Automation deployment.

If your site uses ...

Take this action

vRealize Automation Designer, formerly vCloud Automation Center Designer

If your site includes vRealize Automation Designer, uninstall it. After the upgrade is finished, install the 6.2.x version provided on the VMware Appliance Install download page. For more information about installing and using vRealize Automation Designer, see Uitbreidbaarheid van machine.

An external vRealize Orchestrator appliance

If your deployment uses an external vRealize Orchestrator appliance and it is connected to the Identity Appliance, upgrade vRealize Orchestrator before you upgrade vRealize Automation.