Problemen met de Windows-prestatiemeter kunnen ervoor zorgen dat wordt gemeld dat IaaS-servers niet verbonden zijn.

Probleem

Nadat u de beheeragent hebt geïnstalleerd of geüpgraded, verzendt de IaaS-server pings naar de vRealize Automation-appliance. Het probleem treedt op wanneer de pings mislukken, waardoor de status Niet verbonden voor de IaaS-server wordt weergegeven op het tabblad Cluster van de beheerinterface van de vRealize Automation-appliance.

Op de IaaS-server wordt in het bestand All.log van de beheeragent een fout weergegeven die vergelijkbaar is met het volgende.

[UTC:2019-05-25 16:09:37 Local:2019-05-25 18:09:37] [Error]: [sub-thread-Id="4" context="" token=""] System.InvalidOperationException: Category does not exist.
at System.Diagnostics.PerformanceCounterLib.CounterExists(String machine, String category, String counter)
at System.Diagnostics.PerformanceCounter.InitializeImpl()
at System.Diagnostics.PerformanceCounter.NextSample()
at System.Diagnostics.PerformanceCounter.NextValue()
at VMware.IaaS.Component.Metrics.MetricsUtility.CalculateMachineProcessorMeasure(Int32 samplePeriodMilliseconds)
at VMware.IaaS.Management.Agent.ManagementEndpointService.CollectEnvironmentInfo()
at VMware.IaaS.Management.Agent.ManagementEndpointService.<PingAsync>d__0.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1.ConfiguredTaskAwaiter.GetResult()
at VMware.IaaS.Management.Agent.ManagementAgent.<<PingManagementEndpointAsync>b__1f>d__23.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at VMware.IaaS.Management.Agent.ManagementAgent.<ExecutePeriodicAction>d__8.MoveNext()

Oorzaak

Er is een bekend probleem waarbij de Windows-prestatiemeters in de loop der tijd beschadigd raken, wat leidt tot de fout.

Oplossing

Bouw alle prestatiemeters opnieuw, inclusief uitbreidbare meters en meters van derden.

  1. Open een opdrachtprompt als beheerder op de IaaS-server.
  2. Bouw de meters opnieuw:

    cd C:\Windows\system32

    lodctr /R

    cd C:\Windows\sysWOW64

    lodctr /R

  3. Synchroniseer de meters opnieuw met Windows Management Instrumentation (WMI):

    WINMGMT.EXE /RESYNCPERF

  4. Stop en herstart de Performance Logs and Alerts-service.
  5. Stop de Windows Management Instrumentation-service en start deze opnieuw.

Volgende stappen

Als het probleem met deze stappen niet is opgelost, raadpleegt u Microsoft-ondersteuningsartikel 300956 of Microsoft-ondersteuningsartikel 2554336. In de artikelen wordt beschreven hoe u handmatig de bijbehorende registerrecords opnieuw kunt instellen. U wordt aanbevolen eerst een back-up van het register te maken.