Во время синхронизации ресурсов Citrix с Workspace ONE Access возникает исключение из-за общей ошибки в настройке Integration Broker, если соответствующее удостоверение настроено на неверный пул приложений.
Проблема
Во время синхронизации в журнале Integration Broker появляется следующее исключение.
IntegrationBrokerLogger Error 1002 2017-04-04 19:10:38,936 (16) HznXenIntegrationBroker.ApplicationException.ServiceErrorHandler — Подключение к удаленному серверу завершилось неудачей с сообщением об ошибке: «Клиент не может подключиться к точке назначения, указанной в запросе». Убедитесь, что служба в точке назначения запущена и принимает запросы. Проверьте журналы и документацию, чтобы определить, какая служба WS-Management запущена в точке назначения, чаще всего это IIS или WinRM. Если это служба WinRM, выполните следующую команду в точке назначения для анализа и настройки службы WinRM: winrm quickconfig. Подробную информацию см. в разделе справки about_Remote_Troubleshooting по адресу System.Management.Automation.Runspaces.AsyncResult.EndInvoke()
Причина
Эта ошибка возникает, если удостоверение неверно настроено или оно настроено для неверного пула приложений.
Решение
Настройте удостоверение для пула приложений, который подключен к Integration Broker. Этот пул может не быть пулом приложений по умолчанию.
Убедитесь, что выбран верный пул.
- В приложении IIS Manager щелкните Пулы приложений на левой панели.
- Щелкните правой кнопкой мыши пул приложений и выберите Просмотреть приложения.
- Убедитесь, что Integration Broker отображается в списке приложений.
Чтобы настроить удостоверение для пула приложений, следуйте инструкциям в Настройка параметров диспетчера служб IIS для Integration Broker Workspace ONE Access.