В среде высокой доступности vRealize Automation может произойти сбой запуска Identity Manager для управления каталогами после перезапуска службы Horizon Workspace.

Проблема

Сбой запуска службы Horizon Workspace происходит из-за ошибки, аналогичной следующей:

Error creating bean with name
  'liquibase' defined in class path resource [spring/datastore-wireup.xml]:
  Invocation of init method failed; nested exception is
  liquibase.exception.LockException: Could not acquire change log lock. Currently
  locked by fe80:0:0:0:250:56ff:fea8:7d0c%eth0
  (fe80:0:0:0:250:56ff:fea8:7d0c%eth0) since 10/29/15 

Причина

Identity Manager может не запуститься в среде высокой доступности из-за проблем со служебной программой управления данными liquibase, используемой vRealize Automation.

Решение

  1. Войдите в сеанс консоли на устройстве vRealize Automation как пользователь root.
  2. Остановите службу Horizon Workspace с помощью следующей команды.

    #service horizon-workspace stop

  3. Откройте оболочку Postgres как привилегированный пользователь.

    su postgres

  4. Перейдите в нужный каталог bin.

    cd /opt/vmware/vpostgres/current/bin

  5. Подключитесь к базе данных.

    psql vcac

  6. Из saas.databasechangeloglock выполните следующий запрос SQL.

    select * from databasechangeloglock;

    Если выходные данные содержат значение t (true), разблокировку нужно выполнить вручную.

  7. Для этого выполните следующий запрос SQL.

    update saas.databasechangeloglock set locked=FALSE, lockgranted=NULL, lockedby=NULL where id=1;

  8. Из saas.databasechangeloglock выполните следующий запрос SQL.

    select * from databasechangeloglock;

    Выходные данные должны содержать значение f (false), указывающее, что разблокировка выполнена.

  9. Выйдите из базы данных Postgres vcac.

    vcac=# \q

  10. Закройте оболочку Postgres.

    exit

  11. Запустите службу Horizon Workspace.

    #service horizon-workspace start