View Composer 升級程序有特定需求和限制。

若要執行 View Composer 安裝程式,您必須是具有系統上管理員權限的網域使用者。

安全性相關需求

  • View Composer 需要由 CA (憑證授權單位) 簽署的 SSL 憑證。如果您要在安裝 View Composer 之後將現有憑證或預設的自我簽署憑證取代為新憑證,則必須匯入新憑證並且執行 SviConfig ReplaceCertificate 公用程式,將新憑證繫結至 View Composer 所使用的連接埠。

    如果您在相同的 Windows Server 電腦上安裝 vCenter Server 和 View Composer,則它們可以使用相同的 SSL 憑證,但是您必須為每個元件個別設定憑證。

    如需安全憑證需求的完整資訊,請參閱View 安裝》文件中的〈設定 View Server 的 SSL 憑證〉。

  • vCenter Server、View Composer 和 View 伺服器的憑證必須包含憑證撤銷清單 (CRL)。如需詳細資訊,請參閱View 安裝》指南中的〈針對伺服器憑證設定憑證撤銷檢查〉。

  • 確認 View Composer 電腦上執行的應用程式都未使用 Windows SSL 程式庫,這些程式庫需要 Microsoft Secure Channel (Schannel) 安全性套件所提供的 SSLv2。View Composer 安裝程式會停用 Microsoft Schannel 上的 SSLv2。應用程式 (如 Tomcat (使用 Java SSL) 或 Apache (使用 OpenSSL)) 不受此限制影響。預設也會停用 SSLv3、TLSv1.0 和 RC4。如需更多資訊,請參閱《View 安全性》文件中的〈View 中已停用的舊版通訊協定和加密〉。

  • 若要強化 View Composer 的安全性,請在安裝 View Composer 服務的 Windows Server 電腦上停用弱式密碼編譯加密套件。請參閱View 安裝》文件中的〈停用 View Composer Server 上的弱式密碼編譯加密套件〉。

  • 您可能需要進行安全通訊協定組態變更,才能繼續與 vSphere 相容。如果可能,請先對 ESXi 和 vCenter Server 套用修補程式以支援 TLSv1.1 和 TLSv1.2,然後再升級 View Composer。如果您無法套用修補程式,請先在 View Composer 上重新啟用 TLSv1.0 再進行升級。如需詳細資訊,請參閱 在從 View Composer 連往 vCenter 和 ESXi 的連線上啟用 TLSv1.0

  • Horizon 7 7.0.3 版起,您可以為 View Composer 啟用摘要式存取驗證方法以提供增強的安全性。如需詳細資訊,請參閱 為 View Composer 啟用摘要式存取驗證