即便您已採取步驟來避免在轉換主要虛擬機器時發生 Microsoft Sysprep 問題,轉換工作仍在後續嘗試中逾時。

問題

第一次嘗試發佈映像時,您會在 [活動] 頁面中看到映像轉換程序因 appx 套件的相關 Microsoft Sysprep 問題而失敗,並出現逾時錯誤。根據自訂已匯入映像虛擬機器的 Windows 作業系統中所述的最佳化步驟並解決任何 Microsoft Sysprep 錯誤記錄檔中所述的問題之後,您需要嘗試轉換映像。在這第二次的嘗試中,您在 [活動] 頁面中看到訊息:「等待虛擬機器電源關閉已達 20 分鐘:請將映像轉換回虛擬機器」。

原因

發生此狀況的原因在於第二次嘗試執行的 Microsoft Sysprep 程序停滯或沒有回應。請使用下列步驟來因應此問題。

解決方案

  1. 確保根據 Microsoft Sysprep 錯誤記錄以及 VMware KB 2079196Microsoft KB 2769827 中的錯誤訊息來處理 Microsoft Sysprep 問題。
  2. 在主要虛擬機器中檢查 VMware DaaS Agent 服務,並確定其啟動類型設為自動
  3. 將主要虛擬機器重新開機。
  4. 在重新開機的主要虛擬機器上重新嘗試執行轉換程序。