Horizon Client 中的 USB 重新導向可能會發生各種問題。

問題

Horizon Client 中的 USB 重新導向無法將本機裝置提供給遠端桌面平台或應用程式使用,或是有些裝置無法在 Horizon Client 中重新導向。

原因

USB 重新導向可能基於下列原因而無法正確或如預期般運作。

  • 裝置是複合 USB 裝置,並且預設會封鎖它包含的其中一個裝置。例如,預設會封鎖包含滑鼠的聽寫裝置,因為預設會封鎖滑鼠裝置。若要解決此問題,請參閱設定複合 USB 裝置的裝置分割原則設定
  • 部署已發佈桌面平台和應用程式的 Windows Server 2008 RDS 主機不支援 USB 重新導向。
  • 裝置不適用於 USB 重新導向,或不支援使用已發佈桌面平台和應用程式。如需詳細資訊,請參閱USB 裝置類型的相關限制
  • 不支援網路攝影機重新導向。
  • USB 音訊裝置的重新導向取決於網路的狀態,而且並不可靠。即使處於閒置狀態,一些裝置仍需要高資料流量。
  • 開機裝置不支援 USB 重新導向。若您在從 USB 裝置開機的 Windows 系統上執行 Horizon Client,且將此裝置重新導向至遠端桌面平台,則本機作業系統可能變得沒有反應或無法使用。請參閱 http://kb.vmware.com/kb/1021409
  • 依預設,Windows 版 Horizon Client 不允許您選取鍵盤、滑鼠、智慧卡和音訊輸出裝置來進行重新導向。請參閱 http://kb.vmware.com/kb/1011600
  • RDP 不支援主控台工作階段之 USB HID 的重新導向,也不支援智慧卡讀卡機的重新導向。請參閱 http://kb.vmware.com/kb/1011600
  • Windows Mobile 裝置中心可防止 RDP 工作階段之 USB 裝置重新導向。請參閱 http://kb.vmware.com/kb/1019205
  • 對於某些 USB HID,您必須對虛擬機器進行設定,以更新滑鼠指標位置。請參閱 http://kb.vmware.com/kb/1022076
  • 有些音訊裝置可能會要求對原則設定或登錄設定進行變更。請參閱 http://kb.vmware.com/kb/1023868
  • 網路延遲可能造成裝置互動緩慢,或導致設計為要與本機裝置互動的應用程式出現凍結的情形。容量非常大的 USB 磁碟機可能需要幾分鐘時間才會顯示在 Windows 檔案總管。
  • 以 FAT32 檔案系統格式化的 USB Flash 卡載入速度遲緩。請參閱 http://kb.vmware.com/kb/1022836
  • 本機系統上的程序或服務在您連線至遠端桌面平台或應用程式之前已開啟裝置。
  • 若您重新連接桌面平台或應用程式工作階段,即使桌面平台或應用程式顯示 USB 裝置是可用的,重新導向後的裝置仍會停止運作。
  • USB 重新導向在 Horizon Console 中是停用的。
  • 客體上遺失或停用的 USB 重新導向驅動程式。

解決方案

  • 如果有的話,請使用 VMware Blast 或 PCoIP 而不是 RDP 做為通訊協定。
  • 如果重新導向的裝置在暫時中斷連線後仍無法使用或停止運作,請移除裝置再重新插上,然後重試重新導向。
  • 在 Horizon Console 中,移至原則 > 全域原則,確認 [View 原則] 下的 USB 存取是否設定為允許
  • 在客體的記錄中檢查 ws_vhub 類別的項目,並在用戶端的記錄中檢查 vmware-view-usbd 類別的項目。
    如果使用者不是管理員,或是 USB 重新導向驅動程式未安裝或無法運作,則會在記錄中寫入這些類別的項目。如需這些記錄檔的位置,請參閱 使用記錄檔進行疑難排解及判定 USB 裝置識別碼
  • 在客體上開啟「裝置管理員」,展開「Universal Serial Bus controller」,如果 VMware View 虛擬 USB 主機控制器和 VMware View 虛擬 USB 集線器驅動程式已遺失,則重新安裝,如果已停用,則重新啟用。