Horizon 8 中的 USB 重新導向可能會發生各種問題。

問題

USB 有其限制。如需詳細資訊,請參閱USB 裝置類型的相關限制。掃描器重新導向、即時影音、序列埠重新導向和用戶端磁碟機重新導向有助於避開這些多數使用案例中的限制。VMware 建議使用替代技術 (如果可用),因為音訊、掃描器等 USB 重新導向可能會因為網路延遲而不穩定。

Horizon Client 中的 USB 重新導向無法將本機裝置提供給遠端桌面平台或應用程式使用,或是有些裝置無法在 Horizon Client 中重新導向。

原因

USB 重新導向可能基於下列原因而無法正確或如預期般運作。
  • 確認虛擬作業系統受到支援。請參閱《Horizon 8 安裝和升級》文件中的 Horizon Agent 的需求和考量事項
    備註: 對於部署為 RDSH 伺服器的伺服器作業系統,受支援的裝置存在一些限制。支援儲存磁碟機和一組有限的輕量型裝置類型。例如,不支援 CDROM 裝置。
  • 裝置是複合 USB 裝置,並且預設會封鎖它包含的其中一個裝置。例如,預設會封鎖包含滑鼠的聽寫裝置,因為預設會封鎖滑鼠裝置。若要解決此問題,請參閱設定複合 USB 裝置的裝置分割原則設定
  • 依預設,Windows 版 Horizon Client 不允許您選取鍵盤、滑鼠、智慧卡和音訊輸出裝置來進行重新導向。請參閱設定 USB 裝置的篩選器原則設定
  • 開機裝置不支援 USB 重新導向。若您在從 USB 裝置開機的 Windows 系統上執行 Horizon Client,且將此裝置重新導向至遠端桌面平台,則本機作業系統可能變得沒有反應或無法使用。
  • 網路延遲可能造成裝置互動緩慢,或導致設計為要與本機裝置互動的應用程式出現凍結的情形。容量非常大的 USB 磁碟機可能需要幾分鐘時間才會顯示在 Windows 檔案總管中,且可能適用於用戶端磁碟機重新導向。
  • 以 FAT32 檔案系統格式化的 USB Flash 卡載入速度遲緩。請參閱知識庫文章重新導向 USB 快閃磁碟機可能需要幾分鐘的時間
  • 本機系統上的程序或服務在您連線至遠端桌面平台或應用程式之前已開啟裝置。
  • 若您重新連接桌面平台或應用程式工作階段,即使桌面平台或應用程式顯示 USB 裝置是可用的,重新導向後的裝置仍會停止運作。
  • USB 重新導向在主控台中是停用的。
  • 客體上遺失或停用的 USB 重新導向驅動程式。

解決方案

  • 如果有的話,請使用 VMware Blast 或 PCoIP 而不是 RDP 做為通訊協定。
  • 如果重新導向的裝置在暫時中斷連線後仍無法使用或停止運作,請移除裝置再重新插上,然後重試重新導向。
  • 在主控台中,移至原則 > 全域原則,確認 [View 原則] 下的 USB 存取是否設定為允許
  • 在客體的記錄中檢查 ws_vhub 類別的項目,並在用戶端的記錄中檢查 vmware-view-usbd 類別的項目。
    如果使用者不是管理員,或是 USB 重新導向驅動程式未安裝或無法運作,則會在記錄中寫入這些類別的項目。如需這些記錄檔的位置,請參閱 使用記錄檔進行疑難排解及判定 USB 裝置識別碼
  • 在客體上開啟「裝置管理員」,展開「通用序列匯流排控制器」,如果 VMware View 虛擬 USB 主機控制器和 VMware View 虛擬 USB 集線器驅動程式已遺失,則重新安裝;如果已停用,則重新啟用。