VMware Identity Manager 中的 ICA 內容必須包含與伺服器陣列中 XenApp 伺服器上所設定相同加密層級的加密內容集,否則使用者會無法存取其 Citrix 發佈的應用程式或桌面平台。

問題

當使用者從 VMware Identity Manager 連線至 Citrix 發佈的資源時,系統會顯示下列錯誤訊息。

您沒有適當的加密層級可存取此工作階段

原因

VMware Identity Manager 未設定加密層級。如果 XenApp 伺服器上的加密層級設定為高於 Citrix Receiver 中使用的預設設定,使用者會看見此錯誤。

您必須在 VMware Identity Manager 中設定更高的加密層級。

解決方案

  1. 登入 VMware Identity Manager 主控台。
  2. 按一下目錄 > 虛擬應用程式索引標籤,然後按一下設定
  3. 根據您的部署,在左窗格中按一下 Citrix XenAppCitrix XenDesktop
  4. 同時在 ICA 組態Netscaler ICA 組態區段中進行下列變更。
    1. ICA 用戶端內容文字方塊中,設定下列內容的加密層級:

      EncryptionLevelSession=EncRC5-128

      此範例會加密層級設為 128,但您必須將其修改為 XenApp 伺服器上設定的層級。

    2. ICA 啟動內容文字方塊中輸入或編輯下列內容,以設定加密層級:

      [EncRC5-128]

      DriverNameWin16=pdc128w.dll

      DriverNameWin32=pdc128n.dll

      此範例會加密層級設為 128,但您必須將其修改為 XenApp 伺服器上設定的層級。