嘗試將 NSX Intelligence 應用裝置升級至先前已成功部署但已刪除的較新版本時,可能會收到升級服務包上傳失敗錯誤訊息。

問題

如果您已成功將 NSX Intelligence 應用裝置從較舊版本 (例如,1.1.0.0.0.15887964) 升級至較新版本 (例如,1.1.1.0.0.16275204),但您決定刪除版本 1.1.1.0.0.16275204 以重新部署版本 1.1.0.0.0.15887964,則可能會看到下列錯誤。

升級服務包上傳失敗!升級協調器已處於目標版本。無法重新觸發 UC 升級。

原因

NSX Intelligence 升級協調器 (UC) 已具有來自先前成功升級之較新 NSX Intelligence 服務包版本 (例如 1.1.1.0.0.16275204) 的 NSX Intelligence 升級資訊。

解決方案

  1. 使用 SSH,以企業管理員權限登入 NSX Manager 節點。
  2. 從 CLI,使用下列命令重新啟動升級協調器。
    restart service intelligence-upgrade-coordinator
    
  3. NSX Intelligence 升級協調器成功重新啟動後,請再次嘗試使用相同的 NSX Intelligence 升級服務包來更新您的 NSX Intelligence 應用裝置。