Security Intelligence 啟用失敗。

問題

無法成功完成 Security Intelligence 啟用。您可能已看到以下錯誤訊息之一。
  • 在功能部署之前,叢集狀態必須為「穩定」

    按一下啟用後,可能會顯示此錯誤訊息。

  • 功能啟用所用的時間太長。Kubernetes 網繭無法啟動或向 NSX Manager 登錄失敗。請連絡您的基礎結構管理員以尋求協助。

原因

Security Intelligence 啟用失敗可能是以下原因之一造成的。
  • NSX Application Platform 使用的 Kubernetes 網繭處於降級或不穩定狀態。由於要在此平台上託管 Security Intelligence,因此,如果此平台不穩定,則無法進行啟用。
  • Kubernetes 網繭無法啟用,或嘗試在 Security Intelligence 中登錄 NSX Manager 失敗。

解決方案

  • 若要嘗試解決此問題,請執行與上一節中所列原因對應的下列其中一個建議解決方案。

解決方案

若要嘗試解決此問題,請執行與上一節中所列原因對應的下列其中一個建議解決方案。
  • 如果您收到在功能部署之前,叢集狀態必須為「穩定」錯誤訊息,請解決導致部署了 NSX Application Platform 的 Kubernetes 叢集處於不穩定狀態的問題。如需相關資訊,請參閱隨 3.2 版及更新版本的 VMware NSX 說明文件集提供的Deploying and Managing the VMware NSX Application Platform文件中的〈疑難排解 NSX Application Platform 的問題〉一節。
  • 如果您收到啟用功能耗費過長時間錯誤訊息,請使用以下資訊縮小失敗的根本原因範圍。
    1. 檢查 cluster-api 網繭的記錄。
      1. 使用 root 帳戶登入到 NSX Manager 應用裝置。
      2. 在系統提示下執行以下命令。
        napp-k logs cluster-api-xxxx -c cluster-api 
        使用 napp-k get pods | grep cluster-api 命令搜尋 cluster-api 網繭名稱。自動產生的尾碼會附加到 cluster-api 網繭名稱後面,在上述命令中表示為 -xxxx

      必須能夠從 cluster-api 網繭中存取 Helm 儲存庫。如果在 cluster-api 網繭和 Helm 儲存庫之間存在連接問題,cluster-api 網繭可能無法取得 Helm Chart 並導致它為 Security Intelligence 建立 Kubernetes 資源。連接取決於您的 Kubernetes 基礎結構管理員設定的網路原則和其他防火牆規則。與基礎結構管理員一起進一步調查並解決此問題。

    2. 驗證需要的所有網繭是否能夠啟動。網繭啟動取決於是否可連線 Docker 登錄。如果 Docker 登錄無法連線或下載動作由於驗證或授權原因失敗,Kubernetes worker 節點可能無法下載執行工作負載所需的 Docker 容器映像。按照步驟 1 中所述,檢查連線。目前不支援具有驗證的 Docker 登錄。
    3. 檢查所有網繭是否達到執行中狀態,且所有工作成功完成。
      napp-k get pods | awk '!/Running|Completed/'

      當命令執行成功時,它不會產生任何輸出。下載 Docker 容器映像後,網繭必須能夠啟動和執行。

    4. 對於未處於執行中狀態的網繭,請使用下列 describe 命令來檢查事件。
      napp-k describe pod <pod-name>
      您還可以使用以下命令從記錄中檢查網繭狀態。
      napp-k logs <pod-name>