Security Intelligence 功能已成功啟用,但存在一些已降級的服務。

問題

Security Intelligence 功能已成功啟用,但其健全狀況報告為部分啟動關閉。這些降級的健全狀況會在 Security Intelligence 功能啟用後立即報告,或在其生命週期的稍後階段中報告。

原因

原因可以是以下任何原因。

  1. 無法從 TKC 或上游 Kubernetes worker 節點中存取 Docker 登錄。
  2. Security Intelligence 應用程式網繭無法達到執行中狀態。

解決方案

與 Kubernetes 基礎結構管理員合作,嘗試修正該問題。使用下列可能的解決方案,其分別與前述問題一節中列出的問題對應。

  1. 驗證需要的所有網繭是否能夠啟動。網繭啟動取決於是否可連線 Docker 登錄。如果 Docker 登錄無法連線或下載動作由於驗證或授權原因失敗,Kubernetes worker 節點可能無法下載執行工作負載所需的 Docker 容器映像。修正 Docker 登錄的連線問題,刪除 Security Intelligence 功能,然後再次嘗試啟用該功能。
  2. 檢查所有網繭是否達到執行中狀態,且所有工作成功完成。下載 Docker 容器映像後,網繭必須能夠啟動和執行。對於未處於執行中狀態的網繭,請使用下列 describe 命令來檢查事件。
    napp-k describe pod <pod-name>
    對於未成功完成的工作,請使用下列命令來檢查記錄。
    napp-k logs <pod-name>

如果提供的任何解決方案均無效,請與 VMware 支援部門聯絡以取得進一步協助。