對於 Kubernetes 環境和 Pivotal Cloud Foundry (PCF) 環境,NSX Container Plug-in (NCP) 具有下列相容性需求。

表 1. Kubernetes 環境的相容性需求
軟體產品 版本
NSX-T Data Center 2.3、2.4
容器主機虛擬機器的 Hypervisor
容器主機作業系統
  • RHEL 7.5、7.6
  • Ubuntu 16.04
  • CentOS 7.4、7.5
容器協調工具 Kubernetes 1.12、1.13
Container Host Open vSwitch 2.9.1 (隨附於 NSX-T Data Center 2.3.x)、2.10.2 (隨附於 NSX-T Data Center 2.4.0)
表 2. Cloud Foundry 環境的相容性需求
軟體產品 版本
容器主機虛擬機器的 Hypervisor
容器協調工具
  • Pivotal Application Service 2.3.x 和 Pivotal Operations Manager 2.3.x
  • Pivotal Application Service 2.4.x (2.4.0 除外) 和 Pivotal Operations Manager 2.4.x (2.4.0 除外)