在設定 NSX-T Data Center 後,請於 Arista CloudVision eXchange (CVX) 上完成組態設定程序,以便讓 CVX 與 NSX-T Data Center 互動。

必要條件

NSX-T Data Center 已將 CVX 登錄為強制執行點。

程序

  1. 以根使用者身分登入 NSX Manager,然後執行下列命令來為 CVX 建立指紋,以便與 NSX Manager 通訊:
    openssl s_client -connect <IP address of nsx-manager>:443 | openssl x509 -pubkey -noout | openssl rsa -pubin -outform der | openssl dgst -sha256 -binary | openssl base64
    輸出範例:
    depth=0 C = US, ST = CA, L = Palo Alto, O = VMware Inc., OU = NSX, CN = nsx-mgr
    verify error:num=18:self signed certificate
    verify return:1
    depth=0 C = US, ST = CA, L = Palo Alto, O = VMware Inc., OU = NSX, CN = nsx-mgr
    verify return:1
    writing RSA key
    S+zwADluzeNf+dnffDpYvgs4YrS6QBgyeDry40bPgms=
  2. 從 CVX CLI 執行下列命令:
    cvx
    no shutdown
    service pcs
    no shutdown
    controller <IP address of nsx-manager>
    username <NSX administrator user name>
    password <NSX administrator password>
    enforcement-point cvx-default-ep
    pinned-public-key <thumbprint for CVX to communicate with NSX
    				  Manager>
    notification-id <notification ID created while registering CVX with NSX>
    end
    
  3. 從 CVX CLI 執行下列命令以檢查組態:
    show running-config
    輸出範例:
    cvx
          no shutdown
       source-interface Management1
       !
       service hsc
          no shutdown
    
       !
       service pcs
          no shutdown
          controller 192.168.2.80
          username admin
          password 7 046D26110E33491F482F2800131909556B
          enforcement-point cvx-default-ep
          pinned-public-key sha256//S+zwADluzeNf+dnffDpYvgs4YrS6QBgyeDry40bPgms=
          notification-id a0286cb6-de4d-41de-99a0-294465345b80
  4. 在連線到實體伺服器的實體交換器乙太網路介面上設定標籤。在由 CVX 管理的實體交換器上執行下列命令。
    configure terminal
    interface ethernet 4
    tag phy_app_server
    end
    copy running-config startup-config
    Copy completed successfully.
  5. 執行下列命令以驗證交換器的標籤組態:
    show running-config section tag
    輸出範例:
    interface Ethernet4
       description connected-to-7150s-3
       switchport trunk allowed vlan 1-4093
       switchport mode trunk
       tag sx4_app_server
    

    在已標記的介面上使用 ARP 所學習的 IP 位址會與 NSX-T Data Center 共用。

  6. 登入 NSX Manager 以針對 CVX 所管理的實體工作負載建立和發佈防火牆規則。如需如何建立規則的詳細資訊,請參閱安全性。例如:

    NSX-T Data Center 中發佈的 NSX-T Data Center 原則和規則,會在由 CVX 管理的實體交換器上顯示為動態 ACL。

    如需詳細資訊,請參閱 CVX HA 設定CVX HA 虛擬 IP 設定以及實體交換器 Mlag 設定