VMware Tools 10.1.7 版本說明

|

更新日期:2017 年 5 月 31 日

VMware Tools | 2017 年 5 月 18 日 | 組件編號 5541682

查看這些版本說明的新增項目和更新。

版本說明的內容

此版本說明涵蓋下列主題:

新增功能

VMware Tools 是公用程式套件,可用來提升虛擬機器的客體作業系統所展現的效能,並改善虛擬機器的管理效率。

  • VMware Tools 支援 10.1.7 的客體作業系統
    • windows.iso 支援 Windows Vista 及更新版本。
    • linux.iso 支援 Linux 客體作業系統 Red Hat Enterprise Linux (RHEL) 及更新版本、SUSE Linux Enterprise Server (SLES) 11 及更新版本、Ubuntu 10.04 及更新版本。它也支援具有 glibc 版本 2.5 及更新版本的其他發行版本。
    • darwin.iso 支援 Mac OS X 版本 10.11 及更新版本。
    • freebsd.iso 支援 FreeBSD 版本。
    • solaris.iso  支援 Solaris 版本。
  • 驅動程式及憑證:已更新 VMXNET3 驅動程式。
  • 已解決的問題:此版本的 VMware Tools 10.1.7 解決了記錄在已解決的問題一節中的問題。

舊版本 VMware Tools

如需舊版本 VMware Tools 10.0.0 的資料,請參閱 VMware Tools 說明文件頁面。

開始之前

一些生命週期結束之客體作業系統的 VMware Tools ISO 映像會予以凍結。部分 ISO 映像不會隨附在 ESXi 的 tools-light VIB 中。如需詳細資料,請參閱 VMware Tools 說明文件頁面。所有 VMware Tools ISO 映像可透過 http://my.vmware.com 下載。

VMware Tools for Windows 有 32 位元和 64 位元安裝程式可執行檔 (.exe) 可供下載。提供這些檔案是為了方便您在 Windows 客體作業系統中存取與安裝 VMware Tools。

有關升級至 ESXi 5.5 Update 3b 或更新版本的重要注意事項

如需在使用舊版 Horizon View Agent 時,將 ESXi 主機升級至 ESXi 5.5 Update 3b 或 ESXi 6.0 Update 1 或更新版本所發生之不相容問題的解決方法和一般準則,請參閱知識庫文章:

國際化

VMware Tools 10.1.7 提供下列語言版本:

  • 英文
  • 法文
  • 德文
  • 西班牙文
  • 義大利文
  • 日文
  • 韓文
  • 簡體中文
  • 繁體中文

相容性

VMware Tools 10.1.7 與 VMware vSphere ESXi 5.5 及更新版本、VMware Workstation 12.0 和 VMware Fusion 8.0 的支援版本相容。如需詳細資訊,請參閱《VMware 相容性指南》。

VMware Tools 10.1.7 在搭配虛擬裝置可支援所需功能的 VMware Workstation 12.0、VMware Fusion 8.0 和 VMware vSphere 版本使用時,可支援 Windows 客體上的 DirectX 10.0 和 OpenGL 3.3。Windows 和 Linux 適用的 VMware 客體作業系統 OpenGL 驅動程式僅支援 OpenGL 3.3 核心設定檔。不支援 OpenGL 3.3 相容性設定檔。對於相容性設定檔,OpenGL 客體驅動程式僅支援版本 3.0。

覆寫作業系統隨附之 Linux 核心模組的 VMware Tools 安裝程式選項已過時。在未來版本的 VMware Tools for Linux 中,會從安裝程式中移除覆寫選項。

客體作業系統自訂支援

客體作業系統自訂支援對照表提供支援自訂的客體作業系統的相關詳細資料。

此版本的安裝及升級

VMware Tools 可從產品下載頁面下載。

VMware Tools 作業系統特定套件可從 http://packages.vmware.com/tools/releases/index.html 下載。如需安裝 OSP 的詳細資訊,請參閱 ESXi 5.x 和 6.x 版適用之作業系統特定套件的《VMware Tools 安裝指南》。

VMware Tools 的安裝步驟會根據 VMware 產品和您已安裝的客體作業系統而有所不同。如需在多數 VMware 產品中安裝 VMware Tools 的一般步驟,請參閱 VMware Tools 一般安裝指示 (1014294)。若要將 productLocker 設定為指向共用資料存放區,請參閱 KB 2004018

如需安裝、升級和設定 VMware Tools 的特定指示,請參閱 VMware Tools 說明文件頁面。

升級資訊

針對 VMware Tools 未來版本的升級支援

升級支援可讓隨附於 ESXi、已到達結束支援的舊版 VMware Tools 升級至在舊版 ESXi 結束支援時發行、同時隨附於接續 ESXi 版本的較新版本 VMware Tools。

支援 ESXi 5.0 和 ESXi 5.1 VMware Tools

  • 延伸支援 - ESXi 5.0 和 ESXi 5.1 隨附的 VMware Tools 版本可享有延伸支援
  • 升級 - 不支援在 ESXi 5.0 和 ESXi 5.1 上針對舊版客體作業系統將 VMware Tools 升級為版本 10.0.12。ESXi 5.0 和 5.1 上支援執行 VMware Tools 10.0.12 的虛擬機器。

升級影響

升級支援隱含表示使用者會遵循一個兩步驟的升級程序,以在非舊版客體作業系統上取得 VMware Tools 10.1.0 之後的版本

  1. 在 ESXi 5.5 上將隨附於 ESXi 5.0 或 ESXi 5.1 的 VMware Tools 從 9.4.6 升級為較新版本的 VMware Tools 版本,在較新版本的 ESXi 上升級為 VMware Tools 10.1.0。
  2. 將 VMware Tools 升級為更新版本

針對簡易升級,請升級為隨附 ESXi 的支援版本之 VMware Tools。 

VMware Tools 與 ESXi 具有回溯與向上相容性。較新版本的 VMware Tools 與支援的較舊 ESXi 版本相容,反之亦然。針對 VMware ESXi 5.5 (修補程式版本 ESXi550-201608001)、VMware ESXi 6.0 (修補程式版本 ESXi600-201608001) 及更新版本上的舊版客體作業系統,VMware Tools 的 10.0.12 版升級是所支援的最終升級。

VMware Tools 安裝的 Windows 客體驅動程式

VMware Tools 10.1.7 在 Windows 客體作業系統上支援下列驅動程式版本。

    硬體驅動程式
    驅動程式
    版本

    VMCI

    9.8.6.0

    VSOCK

    9.8.8.0

    PVSCSI

    1.3.8.0

    WDDM

    8.15.1.50

    XPDM

    12.1.8.0

    VMXNET3

    1.7.3.2

    VMXNET2

    2.2.0.0

    VMMOUSE

    12.5.7.0

    VMUSBMOUSE

    12.5.7.0

    VMAUDIO

    5.10.0.3506

    軟體驅動程式
    驅動程式
    版本
    VMRAWDISK.SYS 1.1.0.1
    VMMEMCTL.SYS 7.4.1.1
    VMHGFS.SYS 11.0.14.2 - 適用於 Windows Vista 及更新版本的作業系統
    VSEPFLT.SYS 10.1.0.0
    VNETFLT.SYS 10.1.0.0 - 適用於核心模式程式碼簽署
    VNETWFP.SYS 10.1.0.0

已解決的問題

  • 接收端調整功能對於 Windows 8 和 Windows 2012 Server 及更新版本上的 VMXNET3 沒有作用
    此問題是由 VMXNET3 驅動程式的更新所導致;該更新處理了新增於 NDIS 6.30 版的 RSS 功能,但使調整功能無法使用。此問題出現在 1.6.6.0 到 1.7.3.0.的 VMXNET3 驅動程式版本中。此問題影響到具有 VMware Tools 9.4.15 及更新版本的 Windows 客體作業系統。

    已在此版本中解決此問題。

舊版中的已知問題

若要檢視舊版中適用的已知問題清單,請按一下這裡

  • VMware Tools 10.1.0 與 VMware Site Recovery Manager 6.1.1 或更早版本不相容
    在由 VMware Site Recovery Manager 6.1.1 或更早版本管理的虛擬機器上,將 VMware Tools 升級至 10.1.0 會中斷 VMware Site Recovery Manager 工作流程。VMware Site Recovery Manager 6.1.2 和 6.5 版本與 VMware Tools 10.1.0 相容。

    因應措施:在將 VMware Tools 安裝或升級至 10.1.0 版之前,先將 VMware Site Recovery Manager 升級至 6.1.2 或 6.5 版。如果虛擬機器正由 VMware Site Recovery Manager 6.1.1 或更早版本管理,請避免將 VMware Tools 安裝或升級至 10.1.0 版。此相容性需求亦適用於各種 Linux 散發所封裝的 open-vm-tools 10.1.0。如需相容性的詳細資訊,請參閱 VMware 產品互通性對照表
  • 嘗試在 FreeBSD 6.x 或 7.x 客體作業系統上安裝 VMware Tools 可能會失敗,並顯示錯誤
    嘗試在 FreeBSD 6.x 或 7.x 客體作業系統上安裝 VMware Tools 可能會失敗,並顯示類似以下的錯誤:

    Guest operating system daemon: failed
    Attempting to run vmtoolsd after installation will result in the following error
    "Segmentation fault: 11 (core dumped)"


    因應措施:在 FreeBSD 6.x 或 7.x 虛擬機器上安裝 VMware Tools 10.1.0 之前,請執行下列操作
    1. 建立檔案 (若尚未建立)
       
       /etc/libmap.conf
    2. 將下列內容新增至 /etc/libmap.conf 檔案

       [/usr/local/lib/vmware-tools/]
       libpthread.so.2 libthr.so.2
       libpthread.so libthr.so


    如果已安裝 VMware Tools 10.1.0,請執行下列操作
    1. 使用下列內容來更新 /etc/libmap.conf

       [/usr/local/lib/vmware-tools/]
       libpthread.so.2 libthr.so.2
       libpthread.so libthr.so
    2. 透過執行 /usr/local/bin/vmware-config-tools.pl 來完成組態

    備註:此因應措施不適用執行 FreeBSD 7.x 之後版本的虛擬機器。

  • open-vm-tools 中的 Common Agent Framework 在 Ubuntu 14.04 中無法建置
    open-vm-tools 中的 Common Agent Framework 在具有的 rabbitmq-c 版本低於 0.8.0 的 Ubuntu 14.04 中無法建置

    因應措施:將 rabbitmq-c 升級為版本 0.8.0 或更新版本,以在 Common Agent Framework 中取得 TLSv1.2 支援。
  • vmusr 外掛程式在 Solaris 10 Update 11 上不會載入
    當 VMware Tools 10.1 在 Solaris 10 U11 客體作業系統上執行時,不會載入下列 vmusr 外掛程式:
    • libdesktopEvents.so
    • libdndcp.so
    • libresolutionSet.so

    此問題可能也會發生在 Solaris 版本 11.2 中。

    因應措施:升級為 Solaris 11.3。
  • 使用 VMware Tools 10.0.x 時,Linux 核心中可能會載入重複的驅動程式
    /lib/modules/<核心版本>/ 直接安裝驅動程式時,就會發生此問題。這可能導致 VMware Tools 不正確地偵測驅動程式,造成安裝不需要的驅動程式。
  • 因應措施:若要因應此問題,請在安裝或重新安裝 VMware Tools 之前,在 /lib/modules/<核心版本>/ / 的子目錄中安裝模組。

    例如,
    cd /lib/modules/$(uname -r)/
    mkdir foobar
    mv foo.ko bar.ko foobar/
    depmod -a

     

摺疊舊版已知問題清單