更新日期:2020 年 11 月 5 日

VMware Tools | 2020 年 11 月 5 日 | 組建編號 17030940

查看這些版本說明的新增項目和更新。

版本說明的內容

此版本說明涵蓋下列主題:

新增功能

  • OSS 更新:
    • OpenSSL 版本已升級至 1.0.2v。
    • libpng 版本已升級至 1.6.37。
    • libxml2 版本已升級至 2.9.10。

舊版本 VMware Tools

  • 如需舊版 VMware Tools 的資料,請參閱 VMware Tools 說明文件頁面。

開始之前

  • VMware Tools 10.3.23 支援下列客體作業系統:
    • linux.iso 支援 Linux 客體作業系統 Red Hat Enterprise Linux (RHEL) 6、SUSE Linux Enterprise Server (SLES) 11、Ubuntu 12.04。它也支援具有 glibc 版本 2.5 及更新版本的其他發行版本。

      對於上述客體作業系統的更新版本、Red Hat Enterprise Linux (RHEL) 7 及更新版本、SUSE Linux Enterprise Server (SLES) 12 及更新版本、Ubuntu 14.04 及更新版本,建議您安裝作業系統廠商提供的 open-vm-tools。如需指示,請參閱安裝 open-vm-tools。如需更多詳細資料,請參閱知識庫 2073803
       
  • VMware Tools ISO 映像會針對某些生命週期結束的客體作業系統進行凍結。部分 ISO 映像不會隨附於 tools-light VIB 中的 ESXi。如需詳細資料,請參閱 VMware Tools 說明文件頁面。所有 VMware Tools ISO 映像皆可透過 http://my.vmware.com 下載。

    注意:
    對於其他 ISO,請使用 VMware Tools 10.3.10 或 11.0.0 發行版本。

有關升級至 ESXi 6.5 或更新版本的重要注意事項

不相容問題的解決方法和一般準則:在使用舊版 Horizon View Agent 時,若要將 ESXi 主機升級至 ESXi 6.5 或更新版本,請參閱知識庫文章:

國際化

VMware Tools 10.3.23 提供下列語言版本:

  • 英文
  • 法文
  • 德文
  • 西班牙文
  • 義大利文
  • 日文
  • 韓文
  • 簡體中文
  • 繁體中文

終止功能支援注意事項

  • VMware Tools 10.3.5 凍結功能支援 tar 工具和 OSP 
    隨附於 VMware Tools 10.3.5 版的 tar 工具 (linux.iso) 和 OSP 將繼續受到支援。不過,VMware Tools 10.3.5 之後的版本將僅包含嚴重問題修正和安全性修正,這些類型的 VMware Tools (tar 工具和 OSP) 將不支援任何新功能。建議客戶針對支援 open-vm-tools 的作業系統使用 open-vm-tools。如需不同類型 VMware Tools 的詳細資訊,請參閱 https://blogs.vmware.com/vsphere/2016/02/understanding-the-three-types-of-vm-tools.html

相容性注意事項

  • 從 VMware Tools 10.2.0 版開始,適用於 FreeBSD、以 Perl 指令碼為基礎的 VMware Tools 安裝已中止。因此,僅能透過直接從 FreeBSD 套件存放庫取得的 open-vm-tools 套件來支援 FreeBSD 系統。適用於 open-vm-tools 10.1.0 及更新版本的 FreeBSD 套件可透過 FreeBSD 套件存放庫來取得。

客體作業系統自訂支援

《客體作業系統自訂支援對照表》詳細列出受支援自訂客體作業系統的相關資料。

互通性對照表

VMware 產品互通性對照表提供目前及舊版本 VMware 產品相容性的相關詳細資料。 

此版本的安裝及升級

VMware Tools 可從產品下載頁面下載。

VMware Tools 作業系統特定套件可從 http://packages.vmware.com/tools/releases/index.html 下載。如需安裝 OSP 的詳細資訊,請參閱作業系統特定套件適用的 VMware Tools 安裝指南

VMware Tools 的安裝步驟會根據 VMware 產品和您已安裝的客體作業系統而有所不同。如需在多數 VMware 產品中安裝 VMware Tools 的一般步驟,請參閱 VMware Tools 一般安裝指示 (1014294)。若要將 productLocker 設定為指向共用資料存放區,請參閱 KB 2004018

如需安裝、升級和設定 VMware Tools 的特定指示,請參閱 VMware Tools 說明文件頁面。

注意: 

如果您使用的是早於 9.4 的 VMware Tools 版本,請參閱 VMware Tools 10.1.0 版本說明以取得特定的升級準則。

已解決的問題

  • 在舊版的 Linux (包括 RHEL5) 上安裝 VMware Tools 失敗。

    在升級至 VMware Tools 10.3.23 版本時,需要 glibc-2.11 或更新版本才能在舊版的 Linux (包括 RHEL5) 上安裝 VMware Tools 成功。

    嘗試在不受支援的 Linux 客體上安裝 VMware Tools 10.3.23 的使用者會導向至知識庫 2147454。此知識庫文章提供準則,選取支援此客體的正確 VMware Tools 版本。

已知問題

  • 拖曳功能在 Ubuntu 中無法正常運作。

    拖曳功能在使用簡易安裝來安裝的 Ubuntu 16.04.4 32 位元虛擬機器中無法正常運作。此外,在相同系統中出現複製和貼上功能失敗的問題。

    注意:在 Workstation 和 Fusion 上執行的 VMware Tools 會有此問題。

    因應措施:

    • 新增 modprobe.blacklist=vmwgfx linux 核心開機選項。
    • 若要存取更大的解析度,請從 VMX 檔案移除 svga.guestBackedPrimaryAware = "TRUE" 選項。
  • Linux 虛擬機器上無法使用共用資料夾掛接。

    如果在 Linux 虛擬機器電源關閉時啟用了共用資料夾功能,則共用資料夾掛接在重新啟動時無法使用。

    注意:在 Workstation 和 Fusion 上執行的 VMware Tools 會有此問題。

    因應措施:

    如果已開啟虛擬機器的電源,請從介面先停用再啟用共用資料夾功能。
    若要永久解決問題,請編輯 /etc/fstab 並新增項目以在開機時自動掛接共用資料夾。
    例如,新增此行:
    vmhgfs-fuse   /mnt/hgfs    fuse    defaults,allow_other    0    0

check-circle-line exclamation-circle-line close-line
Scroll to top icon