更新日期:2019 年 8 月 23 日

VMware Tools | 2018 年 9 月 12 日 | 組建編號 9925305

查看這些版本說明的新增項目和更新。

版本說明的內容

此版本說明涵蓋下列主題:

新增功能

此版本的 VMware Tools 解決了多個 VMware AppDefense 問題。建議 VMware AppDefense 使用者使用 VMware Tools 10.3.2。

備註:VMware Tools 10.3.0 由於 VMXNET3 驅動程式相關問題而已過時。如需詳細資訊,請參閱 KB 57796。安裝或升級至 VMware Tools 10.3.2 或 VMware Tools 的更高版本。此汰換不影響 10.3.0 open-vm-tools。

  • VMware Tools 10.3.2 支援下列客體作業系統:
    • windows.iso 支援 Windows Vista 及更新版本。 
      • VMware Tools 10.3.2 依存且隨附 Microsoft Visual C++ 2017 可轉散發套件 14.0 版。針對 VMware Tools 10.3.2 安裝準備系統時,Microsoft Visual C++ 2017 可轉散發套件會安裝在系統上做為必要條件。不符合必要條件的 Windows 版本不支援安裝或升級至 VMware Tools 10.3.2,客戶應繼續使用 VMware Tools 10.2.x 或更早版本,直到客戶可以修補或更新 Windows 作業系統以符合 VMware Tools 10.3.2 的必要條件為止。 
      • Windows 作業系統層級必要條件
        • Windows Server 2016
        • Windows 10
        • Windows Server 2012
        • Windows 8
        • Windows Server 2008 R2 Service Pack 1 (SP1)
        • Windows 7 SP1
        • Windows Server 2008 Service Pack 2 (SP2)
        • Windows Vista SP2
        • Windows Server 2012 R2 包含 Microsoft Update KB 2919355
        • Windows 8.1 包含 Microsoft Update KB2919355
    • linux.iso 支援 Linux 客體作業系統 Red Hat Enterprise Linux (RHEL) 5 及更新版本、SUSE Linux Enterprise Server (SLES) 11 及更新版本、Ubuntu 10.04 及更新版本。它也支援具有 glibc 版本 2.5 及更新版本的其他發行版本。
    • darwin.iso 支援 Mac OS X 版本 10.11 及更新版本。
    • solaris.iso 支援 Solaris 版本。
  • VMware AppDefense 與 VMware Tools 的整合:VMware Tools 安裝包括 VMware AppDefense,這是一種安全性管理和監控解決方案。此資料中心安全性解決方案的基礎為應用程式控制、偵測及回應。如需詳細資訊,請參閱 VMware Tools 使用者指南
  • OpenGL 驅動程式中的變更:OpenGL 驅動程式已針對錯誤修正和效能改善進行更新
    • 頂點緩衝區物件 (VBO) 最佳化
    • 顯示清單繪圖最佳化
  • VMware Tools 生命週期使用 Windows Update 伺服器中的驅動程式更新:此整合可讓您在 Windows Update 期間更新 PVSCSI 驅動程式。此功能僅支援 Windows Server 2016 的 PVSCSI。
  • 共用資料夾:FUSE 型共用資料夾用戶端可用作替代方案,讓核心模式用戶端支援具有核心版本 3.10 及更新版本的 Linux 發行版。
  • VMware Tools 使用者空間編譯器升級:Windows 版 VMware Tools 10.3.0 的編譯器已升級至 Microsoft Visual Studio 2015。

舊版本 VMware Tools

  • 如需舊版 VMware Tools 的資料,請參閱 VMware Tools 說明文件頁面。

開始之前

有關升級至 VMware Tools 10.3.0 的重要注意事項

不符合必要條件的 Windows 版本不支援安裝或升級至 VMware Tools 10.3.0。建議使用者使用 VMware Tools 10.2.x 或更早版本,直到 Windows 作業系統經過更新,可符合 VMware Tools 10.3.0 的必要條件為止。

注意Windows 版 VMware Tools 10.3.0 會在系統上安裝 Microsoft Visual C++ 2017 可轉散發套件 14.0 版,而這可能需要重新啟動系統。安裝或升級至 VMware Tools 10.3.0 之前,強烈建議 Windows 使用者規劃進行系統重新啟動。

VMware Tools ISO 映像會針對某些生命週期結束的客體作業系統進行凍結。部分 ISO 映像不會隨附於 tools-light VIB 中的 ESXi。如需詳細資料,請參閱 VMware Tools 說明文件頁面。所有 VMware Tools ISO 映像皆可透過 http://my.vmware.com 下載。

VMware Tools for Windows:有 32 位元和 64 位元安裝程式可執行檔 (.exe) 可供下載。提供這些檔案是為了方便您在 Windows 客體作業系統中存取與安裝 VMware Tools。

安裝較新版本的 vmtoolspkg VIB 時,VMware Tools 狀態可能不會變更。這是在 vSphere 5.5.x 和更新版本中發現的限制。若要解決此問題,請先關閉虛擬機器的電源再重新開啟電源,或將主機重新開機。

有關升級至 ESXi 5.5 Update 3b 或更新版本的重要注意事項

不相容問題的解決方法和一般準則:在使用舊版 Horizon View Agent 時,若要將 ESXi 主機升級至 ESXi 5.5 Update 3b 或 ESXi 6.0 Update 1 或更新版本,請參閱知識庫文章:

國際化

VMware Tools 10.3.2 提供下列語言版本:

  • 英文
  • 法文
  • 德文
  • 西班牙文
  • 義大利文
  • 日文
  • 韓文
  • 簡體中文
  • 繁體中文

產品支援注意事項

適用於 VMWare Tools 之 Windows Vista 之前的 ISO 映像已不再隨附於 ESXi。Windows Vista 之前的 ISO 映像可供需要它的使用者下載。如需下載資訊,請參閱產品下載頁面。

相容性注意事項

  • 從 VMware Tools 10.2.0 版開始,適用於 FreeBSD、以 Perl 指令碼為基礎的 VMware Tools 安裝已中止。因此,僅能透過直接從 FreeBSD 套件存放庫取得的 open-vm-tools 套件來支援 FreeBSD 系統。適用於 open-vm-tools 10.1.0 及更新版本的 FreeBSD 套件可透過 FreeBSD 套件存放庫來取得。

客體作業系統自訂支援

《客體作業系統自訂支援對照表》詳細列出受支援自訂客體作業系統的相關資料。

互通性對照表

VMware 產品互通性對照表提供目前及更早版本之 VMware 產品相容性的相關詳細資料。VMware Tools 10.3.0 的 VMware 產品互通性對照表可以適用於 VMware Tools 10.3.2。 

此版本的安裝及升級

VMware Tools 可從產品下載頁面下載。

VMware Tools 作業系統特定套件可從 http://packages.vmware.com/tools/releases/index.html 下載。如需安裝 OSP 的詳細資訊,請參閱作業系統特定套件適用的 VMware Tools 安裝指南

VMware Tools 的安裝步驟會根據 VMware 產品和您已安裝的客體作業系統而有所不同。如需在多數 VMware 產品中安裝 VMware Tools 的一般步驟,請參閱 VMware Tools 一般安裝指示 (1014294)。若要將 productLocker 設定為指向共用資料存放區,請參閱 KB 2004018

如需安裝、升級和設定 VMware Tools 的特定指示,請參閱 VMware Tools 說明文件頁面。

注意:

如果您使用的是早於 9.4 的 VMware Tools 版本,請參閱 VMware Tools 10.1.0 版本說明以取得特定的升級準則。

VMware Tools 安裝的 Windows 客體驅動程式

VMware Tools 10.3.2 在 Windows 客體作業系統上支援下列驅動程式版本。

驅動程式 VMware Tools 10.3.2
硬體驅動程式
vmci

9.8.6.0

vsock

9.8.12.0

pvscsi

1.3.10.0

wddm

8.16.1.0

xpdm

12.1.8.0

vmxnet3

1.8.3.1

vmxnet2

2.2.0.0

vmmouse

12.5.7.0

vmusbmouse

12.5.7.0

vmaudio

5.10.0.3506

efifw 1.0.0.0
軟體驅動程式
vmrawdsk.sys

1.1.1.0

vmmemctl.sys

7.4.2.0

vmhgfs.sys

11.0.34.0

vsepflt.sys

10.3.0.0

vnetflt.sys

10.3.0.0

vnetWFP.sys 

10.3.0.0 

glgxi.sys
1.3.0.0
(Windows Server 2008 R2、Windows Server 2012、Windows Server 2012 R2 和 Windows Server 2016)

已解決的問題

  • 修復選項已從 VMware Tools 安裝程式的控制台移除。

    VMware Tools 安裝程式控制台中的修復選項已由變更選項取代。

    已在此版本中解決此問題。

  • 系統可能會立即重複使用已中止 VMware Tools 服務的處理程序識別碼。

    在 Linux 和 UNIX 之類的作業系統上,系統可能會立即重複使用已停止 VMware Tools 服務的處理程序識別碼 (PID)。因此,VMware Tools 服務初始化指令碼可能會中止新處理程序。 

    如果在系統關閉期間發生此狀況,則具有相同 (重複使用) PID 之其他處理程序的錯誤「結束」作業可能會影響另一個系統服務的循序關閉。

    已在此版本中解決此問題。

  • VMware Tools 處理程序可能需要很長的時間,且會在具有多個 IPv6 路由的 Linux 作業系統中耗用一個核心的 CPU 達到 100%

    在 VMware Tools 10.3.0 之前,收集具有多個 IPv6 路由之 Linux 客體作業系統中的網路介面卡資訊是一種耗時的處理程序,且一個核心的 CPU 使用率會達到 100%。匯出的資料僅包含最多 100 個路由。IPv4 路由優先於 IPv6,導致報告 IPv6 路由時資料遺失。如果有超過 100 個 IPv4 路由,則不會報告 IPv6 路由。

    此效能問題已在此版本中解決。透過在 /etc/vmware-tools/tools.conf 檔案中設定這些值,即可覆寫預設的路由收集行為:

    [guestinfo]
    max-ipv4-routes=0
    max-ipv6-routes=0


    備註:如果未手動設定或設定了無效的值 (超過 100 或小於 0),則 'max-ipv4-routes''max-ipv6-routes' 依預設會設定為 100。將它設定為 0 可停用資料收集。

    已在此版本中解決此問題。

  • 安裝 libvmtools 套件可能在安裝 VMware Tools 時會失敗。

    在 SUSE Linux 12 中安裝了套件 "libvmtools0",但未安裝 open-vm-tools 時,VMware Tools 安裝程式會失敗。設定的目的在於防止不完整安裝。使用者必須同時解除安裝 open-vm-tools 和 libvmtools0 才能安裝 VMware Tools。

    已在此版本中解決此問題。

已知問題

  • AppDefense 驅動程式 glxgi 在事件檢視器中記錄錯誤。

    AppDefense 驅動程式 glxgi 在事件檢視器中記錄類似下列內容的錯誤:

    「glxgi 服務由於下列錯誤無法啟動:連結至系統的裝置並未正常運作。」

    停用客體完整性時發現事件。

    因應措施:無。這些事件不會影響系統,因此可以安全地忽略。

  • VMware Tools 與其他 LSA 保護不相容

    Windows 作業系統元件本機安全性授權 (LSA) 包含本機安全性授權 Server 服務 (LSASS) 處理程序,用來驗證使用者的本機和遠端登入,並強制執行本機安全性原則。 
    Windows 作業系統可為 LSA 提供額外的保護以避免安全性攻擊。啟用此功能時,必須使用本機安全性授權 (LSA) 的檔案簽署服務來簽署任何 LSA 外掛程式。VMware Tools 安裝的 LSA 外掛程式 vmwsu_v1_0.dll 並未以強制方式簽署,且於 LSA 組態中啟用RunAsPPL 時無法載入。畫面上會顯示類似下列內容的錯誤訊息。

    ******************************************************************
    * 此分隔行指出此二進位檔案未正確簽署:\Device\HarddiskVolume4\Windows\System32\VMWSU_V1_0.DLL

    * 並且不符合系統原則。

    * 已嘗試在下列程序中載入二進位檔案:\Device\HarddiskVolume4\Windows\System32\lsass.exe

    * 此並非 CI 中的錯誤,而是失敗的二進位檔案發生問題。

    * 請連絡二進位檔案的擁有者,以正確簽署該二進位檔案。

    ******************************************************************

    因應措施:無。

  • VMware Tools 套件無法完成安裝。

    透過執行安裝程式命令安裝 VMware Tools 時,系統會顯示一個包含進度列的對話方塊。此對話方塊會顯示 VMware Tools 所使用 VC 2017 可轉散發套件的安裝進度。VC 2017 可轉散發套件安裝並未完成,導致一般 VMware Tools 安裝對話方塊無法啟動。

    您可以在類似於以下路徑的暫存資料夾中找到 VMware Tools 安裝記錄檔:

     %temp%\vminst.log 和 %temp%\vmmsi.log

    當 VMware Tools 安裝 Microsoft VC 2017 可轉散發套件時,於已安裝 Microsoft Document Explorer 2008 套件的 Windows Vista Service Pack 2 作業系統中發現到此問題。

    因應措施:若要安裝 VMware Tools, 

    1. 從 Windows Vista Service Pack 2 作業系統解除安裝 Microsoft Document Explorer 2008 套件。 
    2. 再次執行安裝程式以安裝或升級 VMware Tools。
  • VMware Tools 開機啟動驅動程式 glxgi、pvscsi、vsepflt,以及 vsock 產生的事件檢視器驅動程式警告。 

    當您的安全開機虛擬機器具有 Microsoft Hyper-V、使用 Device Guard 啟用以虛擬化為基礎的安全性,並將程式碼完整性原則設定為強制執行時,驅動程式 glxgipvscsivsepfltvsock 可能會產生類似於以下的事件記錄警告。

    記錄檔名稱:      Microsoft-Windows-CodeIntegrity/Operational
    來源:        Microsoft-Windows-CodeIntegrity

    作業記錄:

    警告 

    事件識別碼:      3083    
    層級:         警告

    說明:
    程式碼完整性判斷系統中已載入不符合 WHQL 需求的核心模組 system32\DRIVERS\vsock.sys。
    請洽詢發行者以了解是否有符合 WHQL 標準的核心模組可供使用。 

    因應措施:無。您可以放心忽略這些警告。驅動程式會載入並以一般方式運作。

  • 拖曳功能在 Ubuntu 中無法正常運作

    拖曳功能在使用簡易安裝來安裝的 Ubuntu 16.04.4 32 位元虛擬機器中無法正常運作。此外,在相同系統中出現複製和貼上功能失敗的問題。

    因應措施:

    • 新增 modprobe.blacklist=vmwgfx linux 核心開機選項。
    • 若要存取更大的解析度,請從 VMX檔案移除 svga.guestBackedPrimaryAware = "TRUE" 選項。
  • 升級至 VMware Tools 10.3.0 後應用程式無法啟動。

    在 VMware Tools 安裝期間或安裝後,應用程式失敗並顯示錯誤:
    因為您的電腦遺失 msvcr71.dll 導致程式無法啟動

    升級至 VMware Tools 10.3.0 之後,您可能會看到結尾為 mfc71.dll、90.dll 的 DLL 類似訊息

    當失敗的第三方應用程式未在安裝時於這些 DLL 上新增相依性參考計數時,可能會發生此問題。

    因應措施:

    在這兩種情況下,可以在升級之前或之後執行 Visual C++ 執行階段安裝程式。

  • Linux 虛擬機器上無法使用共用資料夾掛接

    如果在 Linux 虛擬機器電源關閉時啟用了共用資料夾功能,則共用資料夾掛接在重新啟動時無法使用。

    因應措施:如果已開啟虛擬機器的電源,請從介面先停用再啟用共用資料夾功能。

    若要永久解決問題,請編輯 /etc/fstab 並新增項目以在開機時自動掛接共用資料夾。

    例如,新增此行:

    vmhgfs-fuse   /mnt/hgfs    fuse    defaults,allow_other    0    0

  • 在對話方塊上向使用者顯示的知識庫文章連結無法點選。

    如果未滿足作業系統必要條件,則在 Windows 上安裝或升級 VMware Tools 至 10.3.0 會失敗,或在系統未重新開機的情況下,Microsoft VC 執行階段套件的 VMware Tools 相依性無法升級。系統向使用者顯示的對話方塊會指出知識庫文章的 URL。直接按一下連結無法存取此文章。

    因應措施:請在瀏覽器中複製和貼上 URL 文字並導覽至該文章。

  • 安裝或升級至 VMware Tools 10.3.0 可能需要更長的時間,而且可能需要重新啟動 Windows 作業系統。

    安裝程序可能會顯示為進行中,並顯示類似下列的訊息:
    「正在準備 'VMware Tools' 以進行安裝...」

    在此程序期間,系統可能會提示使用者重新啟動作業系統。 

    因應措施:如需詳細資訊,請參閱知識庫 55798

check-circle-line exclamation-circle-line close-line
Scroll to top icon