更新日期:2019 年 10 月 17 日

VMware Tools | 2019 年 10 月 17 日 | 組建編號 14773994

查看這些版本說明的新增項目和更新。

版本說明的內容

此版本說明涵蓋下列主題:

新增功能

  • 強烈建議您升級到此版本的 VMware Tools,如果您正在使用 vRealize Operations Manager 8.0 中的原生服務探索功能,或將 vRealize Operations Service 探索管理套件與舊版 vRealize Operations Manager (7.x 或更早版本) 搭配使用。如需更多詳細資料,請參閱知識庫 75122

舊版本 VMware Tools

  • 如需舊版 VMware Tools 的資料,請參閱 VMware Tools 說明文件頁面。

開始之前

  • VMware Tools 11.0.1 支援下列客體作業系統:
    • windows.iso 支援 Windows Vista 及更新版本。 
      • VMware Tools 11.0.1 依存且隨附 Microsoft Visual C++ 可轉散發套件 (適用於 Visual Studio 2015、2017 和 2019)。針對 VMware Tools 11.0.1 安裝準備系統時,Microsoft Visual C++ 可轉散發套件 (適用於 Visual Studio 2015、2017 和 2019) 會安裝在系統上做為必要條件。不符合必要條件的 Windows 版本不支援安裝或升級至 VMware Tools 11.0.1,客戶應繼續使用 VMware Tools 10.2.x 或更早版本,直到客戶可以修補或更新 Windows 作業系統以符合 VMware Tools 11.0.1 的必要條件為止。有關最新支援的 Visual C++ 下載,請參閱 Microsoft Update KB 2977003
      • Windows 作業系統層級必要條件
        • Windows Server 2019
        • Windows Server 2016
        • Windows 10
        • Windows Server 2012 R2 包含 Microsoft Update KB 2919355
        • Windows 8.1 包含 Microsoft Update KB2919355
        • Windows Server 2012 
        • Windows 8
        • Windows Server 2008 R2 Service Pack 1 (SP1)
        • Windows 7 Service Pack 1 (SP1)
        • Windows Server 2008 Service Pack 2 (SP2)
        • Windows Vista Service Pack 2 (SP2)
    • darwin.iso 支援 Mac OS X 版本 10.11 及更新版本。
    • 如需 linux.iso 的詳細資料,請參閱 VMware Tools 10.3.21 版本說明
    • 如需 solaris.iso 的詳細資料,請參閱 VMware Tools 10.3.10 版本說明
  • VMware Tools ISO 映像會針對某些生命週期結束的客體作業系統進行凍結。部分 ISO 映像不會隨附於 tools-light VIB 中的 ESXi。如需詳細資料,請參閱 VMware Tools 說明文件頁面。所有 VMware Tools ISO 映像皆可透過 http://my.vmware.com 下載。
  • VMware Tools for Windows:有 32 位元和 64 位元安裝程式可執行檔 (.exe) 可供下載。提供這些檔案是為了方便您在 Windows 客體作業系統中存取與安裝 VMware Tools。

有關升級至 ESXi 6.0 或更新版本的重要注意事項

不相容問題的解決方法和一般準則:在使用舊版 Horizon View Agent 時,若要將 ESXi 主機升級至 ESXi 6.0 或更新版本,請參閱知識庫文章:

國際化

VMware Tools 11.0.1 提供下列語言版本:

  • 英文
  • 法文
  • 德文
  • 西班牙文
  • 義大利文
  • 日文
  • 韓文
  • 簡體中文
  • 繁體中文

產品支援注意事項

  • 適用於 VMWare Tools 之 Windows Vista 之前的 ISO 映像已不再隨附於 ESXi。Windows Vista 之前的 ISO 映像可供需要它的使用者下載。如需下載資訊,請參閱產品下載頁面。

終止功能支援注意事項

  • VMTools 的下一個版本將不再可於 Windows Vista SP2 和 Windows Server 2008 SP2 上安裝。
  • 已從 MacOS VMware Tools 11.0.0 中移除佔用驅動程式。
  • VMware Tools 11.0.0 版本凍結對 Solaris 客體的支援。
  • 隨附於 VMware Tools 10.3.5 版的 tar 工具 (linux.iso) 和 OSP 將繼續受到支援。不過,VMware Tools 10.3.5 之後的版本將僅包含嚴重問題修正和安全性修正,這些類型的 VMware Tools (tar 工具和 OSP) 將不支援任何新功能。建議客戶針對支援 open-vm-tools 的作業系統使用 open-vm-tools。如需不同類型 VMware Tools 的詳細資訊,請參閱 https://blogs.vmware.com/vsphere/2016/02/understanding-the-three-types-of-vm-tools.html

相容性注意事項

  • 從 VMware Tools 10.2.0 版開始,適用於 FreeBSD、以 Perl 指令碼為基礎的 VMware Tools 安裝已中止。因此,僅能透過直接從 FreeBSD 套件存放庫取得的 open-vm-tools 套件來支援 FreeBSD 系統。適用於 open-vm-tools 10.1.0 及更新版本的 FreeBSD 套件可透過 FreeBSD 套件存放庫來取得。

客體作業系統自訂支援

《客體作業系統自訂支援對照表》詳細列出受支援自訂客體作業系統的相關資料。

互通性對照表

VMware 產品互通性對照表提供目前及更早版本之 VMware 產品相容性的相關詳細資料。VMware Tools 11.0.0 的 VMware 產品互通性對照表可以適用於 VMware Tools 11.0.1。

此版本的安裝及升級

VMware Tools 可從產品下載頁面下載。

VMware Tools 的安裝步驟會根據 VMware 產品和您已安裝的客體作業系統而有所不同。如需在多數 VMware 產品中安裝 VMware Tools 的一般步驟,請參閱 VMware Tools 一般安裝指示 (1014294)。若要將 productLocker 設定為指向共用資料存放區,請參閱 KB 2004018

如需安裝、升級和設定 VMware Tools 的特定指示,請參閱 VMware Tools 說明文件頁面。

VMware Tools 安裝的 Windows 客體驅動程式

VMware Tools 11.0.1 在 Windows 客體作業系統上支援下列驅動程式版本。

驅動程式 VMware Tools 11.0.1
硬體驅動程式
vmci

9.8.16.0

vsock

9.8.16.0

pvscsi

1.3.15.0

wddm

8.16.07.0000

xpdm

12.1.8.0

vmxnet3

1.8.16.0

vmxnet2

2.2.0.0

vmmouse

12.5.10.0

vmusbmouse

12.5.10.0

vmaudio

5.10.0.3506

efifw 1.0.0.0
軟體驅動程式
vmrawdsk.sys

1.1.5.0

vmmemctl.sys

7.5.4.0

vmhgfs.sys

11.0.40.0

vsepflt.sys

11.0.0.0

vnetflt.sys

11.0.0.0 (適用於核心模式程式碼簽署,僅限 Windows Vista 和 Windows 2008)

vnetWFP.sys 

11.0.0.0 

glgxi.sys

2.2.0.0

giappdef

2.2.0.0

安全性 DLL
vmwsu.dll

2.0.0.0

已解決的問題

  • vmtoolsd 中的記憶體流失。

    當使用 vSphere API ListGuestAliasesListGuestMappedAliases 時,vmtoolsd 會流失記憶體。

    已在此版本中修正此問題。

已知問題

  • 建立靜止快照後,系統在 Windows 裝置管理員中建立陰影複製磁碟分割 (Ghost 磁碟區)。

    在 GPT 磁碟上建立靜止快照之後,隨即會建立 Microsoft 陰影複製磁碟分割。

    因應措施:

    您可以在 VMware tools.conf 檔案中使用以下組態來刪除陰影複製磁碟分割:

    [vmbackup]
    deleteShadowCopyPartition=true

  • 使用任何版本 open-vm-tools 的 Linux 虛擬機器的暫停客體,對某些版本的 SELinux 可能會失敗。

    在執行任何版本的 open-vm-tools 並已啟用 SELinux 的 Linux 客體上,「暫停客體」作業可能會停止且最終會失敗。

    失敗可能會顯示為:
      - 顯示「無法暫停虛擬機器」訊息。
      - 沒有發生任何動作,且「暫停客體」按鈕已停用。IPv4 連線可能已關閉。
      - 發生延遲的暫停,但當虛擬機器繼續時會遺失 IPv4 位址。

    即使是超過 30 秒的明顯「停止」,也是問題的指示。

    如需更多詳細資料,請參閱知識庫 74722

    因應措施:

    selinux-policyselinux-policy-targeted 套件更新為 Linux 廠商提供的最新版本。  如果套件更新無法取得或問題仍存在,請考慮下列因應措施:

    知識庫 74722 中所述,使用 audit2allow 命令來產生建立可本機載入的 SELinux 原則模組,為 vmtools/NetworkManager 拒絕存取建立例外。

  • AppDefense 驅動程式 glxgi 在事件檢視器中記錄錯誤。

    AppDefense 驅動程式 glxgi 在事件檢視器中記錄類似下列內容的錯誤:

    「The glxgi service failed to start due to the following error: A device attached to the system is not functioning.。」

    停用客體完整性時發現事件。

    因應措施:

    這些事件不會影響系統,因此可以安全地忽略。

  • VMware Tools 開機啟動驅動程式 glxgi、pvscsi、vsepflt,以及 vsock 產生的事件檢視器驅動程式警告。 

    當您的安全開機虛擬機器具有 Microsoft Hyper-V、使用 Device Guard 啟用以虛擬化為基礎的安全性,並將程式碼完整性原則設定為強制執行時,驅動程式 glxgipvscsivsepfltvsock 可能會產生類似於以下的事件記錄警告。

    記錄檔名稱:      Microsoft-Windows-CodeIntegrity/Operational
    來源:        Microsoft-Windows-CodeIntegrity

    作業記錄:

    警告 

    事件識別碼:      3083    
    層級:         警告

    說明:
    程式碼完整性判斷系統中已載入不符合 WHQL 需求的核心模組 system32\DRIVERS\vsock.sys。
    請洽詢發行者以了解是否有符合 WHQL 標準的核心模組可供使用。 

    因應措施:

    您可以放心忽略這些警告。驅動程式會載入並以一般方式運作。

  • VMware Tools 套件無法完成安裝。

    透過執行安裝程式命令安裝 VMware Tools 時,系統會顯示一個包含進度列的對話方塊。此對話方塊會顯示 VMware Tools 所使用 VC 2017 可轉散發套件的安裝進度。VC 2017 可轉散發套件安裝並未完成,導致一般 VMware Tools 安裝對話方塊無法啟動。

    您可以在類似於以下路徑的暫存資料夾中找到 VMware Tools 安裝記錄檔:

     %temp%\vminst.log 和 %temp%\vmmsi.log

    當 VMware Tools 安裝 Microsoft VC 2017 可轉散發套件時,於已安裝 Microsoft Document Explorer 2008 套件的 Windows Vista Service Pack 2 作業系統中發現到此問題。

    因應措施:

    若要安裝 VMware Tools, 

    1. 從 Windows Vista Service Pack 2 作業系統解除安裝 Microsoft Document Explorer 2008 套件。 
    2. 再次執行安裝程式以安裝或升級 VMware Tools。
  • 安裝或升級至 VMware Tools 10.3.0 可能需要更長的時間,而且可能需要重新啟動 Windows 作業系統。

    安裝程序可能會顯示為進行中,並顯示類似下列的訊息:
    「正在準備 'VMware Tools' 以進行安裝...」

    在此程序期間,系統可能會提示使用者重新啟動作業系統。 

    因應措施:

    如需詳細資訊,請參閱知識庫 55798

  • 拖曳功能在 Ubuntu 中無法正常運作。

    拖曳功能在使用簡易安裝來安裝的 Ubuntu 16.04.4 32 位元虛擬機器中無法正常運作。此外,在相同系統中出現複製和貼上功能失敗的問題。

    注意:在 Workstation 和 Fusion 上執行的 VMware Tools 會有此問題。

    因應措施:

    • 新增 modprobe.blacklist=vmwgfx linux 核心開機選項。
    • 若要存取更大的解析度,請從 VMX 檔案移除 svga.guestBackedPrimaryAware = "TRUE" 選項。
  • Linux 虛擬機器上無法使用共用資料夾掛接。

    如果在 Linux 虛擬機器電源關閉時啟用了共用資料夾功能,則共用資料夾掛接在重新啟動時無法使用。

    注意:在 Workstation 和 Fusion 上執行的 VMware Tools 會有此問題。

    因應措施:

    如果已開啟虛擬機器的電源,請從介面先停用再啟用共用資料夾功能。
    若要永久解決問題,請編輯 /etc/fstab 並新增項目以在開機時自動掛接共用資料夾。
    例如,新增此行:
    vmhgfs-fuse   /mnt/hgfs    fuse    defaults,allow_other    0    0

  • Solaris 11.4 顯示 VMware Tools 核心模組簽章驗證失敗警告訊息。

    Solaris 驗證開機預設原則在 Solaris 11.4 版本中設為「警告」。載入未簽署的模組時,顯示如下所示的警告訊息:

    「solaris-11.4 krtld:警告:模組 /kernel/drv/amd64/vmmemctl 的簽章驗證失敗」

    因應措施:

    VMware 不對 VMware Tools 版本中的 Solaris 提供已簽署的核心模組。載入每個 VMware Tools 核心模組時,主控台或系統記錄 (/var/log/messages) 中會顯示警告訊息。
    不過,在「警告」模式中時,模組會載入到核心。

check-circle-line exclamation-circle-line close-line
Scroll to top icon