使用者無法從 VMware Identity Manager 使用者入口網站啟動 Horizon 7 或 Horizon 6 應用程式或桌面平台。

問題

使用者無法從 VMware Identity Manager 使用者入口網站啟動 Horizon 7 或 Horizon 6 應用程式或桌面平台,且使用者介面中顯示下列錯誤:

啟動資源時發生錯誤。請聯絡您的 IT 管理員。

原因

如果 Horizon 連線伺服器執行個體上的 SAML 中繼資料在上次同步後已到期,即可能發生此錯誤。

解決方案

  1. VMware Identity Manager 主控台中,按一下目錄 > 虛擬應用程式集合索引標籤。
  2. 選取 Horizon 虛擬應用程式集合,然後按一下同步,再次將 Horizon 資源同步至 VMware Identity Manager
  3. 按一下編輯,以編輯虛擬應用程式集合,在精靈中按下一步,直到顯示最後一頁,然後按一下儲存
    重要: 如果您新增或更新了網路範圍或原則,此步驟非常重要。您必須再次儲存虛擬應用程式集合,以使變更生效。