升級失敗,並顯示「需要憑證驗證組態更新」錯誤。

問題

當您嘗試升級至 VMware Identity Manager 3.3.1 時,系統會顯示下列錯誤訊息並中止升級。

承租人 <tenantName> 在升級之前需要憑證驗證組態更新。預先更新檢查失敗,正在中止升級。

原因

如果上次新增或更新的 CertificateAuthAdapter 憑證是 3.0 之前的版本,則會發生此問題。

解決方案

  1. 登入 VMware Identity Manager 主控台。
  2. 導覽至身分識別與存取管理 > 設定
  3. 連接器頁面中,按一下工作執行緒資料行中的連結。
  4. 按一下驗證配接器索引標籤,然後按一下 CertificateAuthAdapter
  5. 已上傳的 CA 憑證區段中,按一下紅色的 X 圖示以移除憑證。
  6. 按一下儲存
  7. 根和中繼 CA 憑證區段中,按一下選取檔案以重新新增憑證。
  8. 按一下儲存
  9. 返回虛擬應用裝置主控台,然後再次執行升級命令。