您可以將 vSphere Distributed Switch 4.0、4.1、5.0 或 5.1 版升級到更新版本。升級可以使分散式交換器使用僅在更新版本中可用的功能。

開始之前

  • vCenter Server 升級到版本 5.5。

  • 將連線到分散式交換器的所有主機升級到 ESXi 5.5。

執行這項作業的原因和時機

分散式交換器升級是一項非干擾性作業,也就是說,附加到交換器的主機和虛擬機器根本不會停機。

備註︰

若要在升級失敗後能夠還原虛擬機器和 VMkernel 介面卡的連線,請備份分散式交換器的組態。

如果從 vCenter Server 5.1 進行升級,則可以先匯出交換器組態,然後再升級 vCenter Server。如果從 5.1 之前的版本升級 vCenter Server,請先將 vCenter Server 升級到 5.5 版,然後再備份交換器組態。

如果升級未成功,若要使用交換器的連接埠群組和已連線的主機來重新建立交換器,您可以透過選取匯入分散式交換器精靈中的保留原始分散式交換器識別碼和連接埠群組識別碼選項,來匯入交換器的組態檔。

請參閱使用 vSphere Web Client 匯出 vSphere Distributed Switch 組態使用 vSphere Web Client 匯入 vSphere Distributed Switch 組態

程序

  1. vSphere Web Client 中,導覽到分散式交換器。
  2. 在分散式交換器上按一下滑鼠右鍵,然後選取升級分散式交換器
  3. 選取要將交換器升級到的 vSphere Distributed Switch 版本,然後按下一步

    選項

    說明

    版本 5.5.0

    ESXi 5.5 版及更新版本相容。

    版本 5.1.0

    ESXi 5.1 版及更新版本相容。不支援與更新版本的 vSphere Distributed Switch 一起發佈的功能。

    版本 5.0.0

    ESXi 5.0 版及更新版本相容。不支援與更新版本的 vSphere Distributed Switch 一起發佈的功能。

    版本 4.1.0

    與 ESX/ESXi 4.1 版及更新版本相容。不支援與更新版本的 vSphere Distributed Switch 一起發佈的功能。

  4. 檢閱主機相容性,然後按下一步

    該分散式交換器上執行的部分 VMware ESX 執行個體可能與選取的升級版本不相容。請升級或移除不相容的主機,或者選取分散式交換器的其他升級版本。

  5. 檢閱設定,然後按一下完成

結果

vSphere Distributed Switch 升級後便無法還原到舊版。無法新增執行中舊版與新交換器版本不相容的 VMware ESX 主機。