虛擬機器的硬體版本反映出虛擬機器支援的虛擬硬體功能。這些功能對應於您在其上建立虛擬機器的 ESXi 主機上可用的實體硬體。虛擬硬體功能包含 BIOS 和 EFI、可用的虛擬 PCI 插槽、CPU 數目上限、記憶體組態上限以及其他一般硬體特性。

建立虛擬機器時,可以接受預設硬體版本 (對應於建立虛擬機器的主機版本) 或較舊版本。在下列情況中可以使用較舊硬體版本:

  • 標準化虛擬環境中的測試和部署。

  • 如果不需要具備更新版本的功能。

  • 保持與舊版主機的相容性。

硬體版本低於版本 11 的虛擬機器可以在 ESXi 6.0 主機上執行,但不具有硬體版本 11 中的所有可用功能。例如,無法在硬體版本低於版本 11 的虛擬機器中使用 128 個虛擬處理器或 4,080GB 的記憶體。

透過 vSphere Web Client 和 vSphere Client,可以只將虛擬機器升級到最新硬體版本。如果虛擬機器不需要與舊版 ESX/ESXi 主機保持相容,則可以在 ESXi 6.0 主機上升級虛擬機器。在這種情況下,虛擬機器會升級到版本 11。

  • 若要保持與 ESX/ESXi 3.5 主機的虛擬機器相容性,請升級 ESX/ESXi 3.5 主機上的虛擬機器,這會使虛擬機器升級到版本 4。

  • 若要保持與 ESX/ESXi 4.x 主機的虛擬機器相容性,請升級 ESX/ESXi 4.x 主機上的虛擬機器,這會使虛擬機器升級到版本 7。

  • 若要保持與 ESXi 5.0 主機的虛擬機器相容性,請升級 ESX/ESXi 5.0 主機上的虛擬機器,這會使虛擬機器升級到版本 8。

  • 若要保持與 ESXi 5.1 主機的虛擬機器相容性,請升級 ESX/ESXi 5.1 主機上的虛擬機器,這會使虛擬機器升級到版本 9。

  • 若要保持與 ESXi 5.5 主機的虛擬機器相容性,請升級 ESX/ESXi 5.5 主機上的虛擬機器,這會使虛擬機器升級到版本 10。

在下列情況中,虛擬機器的硬體版本可以低於執行該虛擬機器的主機版本:

  • 將建立於 ESX/ESXi 4.x 或更早版本主機上的虛擬機器移轉到 ESXi 5.0 主機。

  • 使用建立於 ESX/ESXi 4.x 或更早版本主機上的現有虛擬磁碟,即可在 ESXi 5.0 主機上建立虛擬機器。

  • 將建立於 ESX/ESXi 4.x 或更早版本主機上的虛擬磁碟新增至建立於 ESXi 5.0 主機上的虛擬機器中。

您可以在主機上建立、編輯和執行不同的虛擬機器版本 (如果主機支援該版本)。有時,主機上的虛擬機器動作會受到限制,或是虛擬機器不具有主機存取權。

表格 1. ESXi 主機和相容的虛擬機器硬體版本

11 版

10 版

9 版

8 版

7 版

4 版

與 vCenter Server 版本的相容性

ESXi 6.0

建立、編輯、執行

建立、編輯、執行

建立、編輯、執行

建立、編輯、執行

建立、編輯、執行

建立、編輯、執行

vCenter Server 6.0

ESXi 5.5

不受支援

建立、編輯、執行

建立、編輯、執行

建立、編輯、執行

建立、編輯、執行

建立、編輯、執行

vCenter Server 5.5 及更新版本

ESXi 5.1

不受支援

不受支援

建立、編輯、執行

建立、編輯、執行

建立、編輯、執行

建立、編輯、執行

vCenter Server 5.1 及更新版本

ESXi 5.0

不受支援

不受支援

不受支援

建立、編輯、執行

建立、編輯、執行

建立、編輯、執行

vCenter Server 5.0 及更新版本

ESX/ESXi 4.x

不受支援

不受支援

不受支援

不受支援

建立、編輯、執行

建立、編輯、執行

vCenter Server 4.x 及更新版本

ESX/ESXi 3.x

不受支援

不受支援

不受支援

不受支援

不受支援

建立、編輯、執行

vCenter Server 3.5 及更新版本

ESXi 6.0 主機不支援硬體版本低於 4 的虛擬機器硬體版本。若要充分使用這些虛擬機器,請升級虛擬硬體。

備註︰

連線到 ESXi 主機或使用 vSphere Client 的vCenter Server 系統時,會將虛擬機器硬體版本 9、10 和 11 的功能限制為硬體版本 8 及更早版本的功能。