當 Microsoft SQL 資料庫設定為不受支援版本的相容模式時,使用該資料庫的 vCenter Server 安裝會失敗。

出現下列錯誤訊息:輸入的資料庫使用者不具有使用所選資料庫安裝及設定 vCenter Server 所需的所需權限。請更正下列錯誤:%s

資料庫版本必須是 vCenter Server 支援的版本。對於 SQL,即使資料庫是受支援的版本,但如果將它設定為以不受支援版本的相容模式執行,仍會發生此錯誤。例如,如果將 SQL 2008 設定為以 SQL 2000 相容模式執行,就會發生此錯誤。

程序

請確定 vCenter Server 資料庫是受支援的版本,並且未設定為以不受支援版本的相容模式執行。請參閱 http://partnerweb.vmware.com/comp_guide2/sim/interop_matrix.php? 上的《VMware 產品互通性對照表》。