針對 vSphere 部署,VMware 提供了作業系統特定套件 (OSP) 做為 VMware Tools 的封裝和散發機制。這些 VMware Tools OSP 使用原生套件格式和標準 (如 rpm deb) 進行封裝。

備註︰

如果您已經安裝開啟虛擬機器工具,建議不要為 Linux 散發建立 OSP。如需有關客體作業系統相容性支援的資訊,請參閱《VMware 相容性指南》

使用 OSP 可提供以下好處:

  • 可以使用客體作業系統的原生更新機制,下載、安裝以及管理 VMware Tools。

  • 可以升級到最新版本的 VMware Tools,而不必升級到最新版本的 vSphere。

  • 由於 VMware Tools OSP 遵循特定 Linux 作業系統的最佳做法和標準,因此 OSP 使用標準機制來判定套件之間的相依性。透過這些機制,不一定要使用圖形元件,就可以稽核虛擬機器上的套件。

  • 在 VMware Tools 安裝期間可使用標準作業系統工具檢查 OSP。透過此程序,可以輕鬆判定要安裝的元件並確認套件的有效性。

重要事項︰

如果要使用原生更新機制 (而不是 vCenter Server) 來管理 VMware Tools 的更新,請使用 OSP。如果使用 OSP,則在虛擬機器的摘要索引標籤上,VMware Tools 的狀態為 [受管理的客體]。[受管理的客體] 狀態表示您無法使用 vCenter Server 管理 VMware Tools,也無法使用 vSphere Update Manager 升級 VMware Tools。

如需詳細資訊,請前往 VMware 作業系統特定套件網站,網址為:http://www.vmware.com/download/packages.html