若要自訂客體作業系統,必須對虛擬機器和客體進行設定,使其符合 VMware Tools 和虛擬磁碟需求。根據客體作業系統類型,可能還需要符合其他需求。

VMware Tools 需求

若要在複製或部署期間自訂客體作業系統,必須將最新版本的 VMware Tools 安裝在虛擬機器或範本上。如需有關 VMware Tools 支援對照表的資訊,請參閱《VMware 產品互通性對照表》,網址為:http://www.vmware.com/resources/compatibility/sim/interop_matrix.php

虛擬磁碟需求

自訂的客體作業系統必須安裝在虛擬機器組態中做為 SCSI 節點 0:0 而附加的磁碟上。

Windows 需求

自訂 Windows 客體作業系統需要滿足以下條件:

  • 必須在 vCenter Server 系統中安裝 Microsoft Sysprep 工具。請參閱 安裝 Microsoft Sysprep 工具

  • 執行虛擬機器的 ESXi 主機必須是 3.5 或更新版本。

多個 Windows 作業系統支援自訂客體作業系統。

Linux 需求

自訂 Linux 客體作業系統要求 Linux 客體作業系統中已安裝 Perl。

多個 Linux 發佈支援自訂客體作業系統。

確認客體作業系統的自訂支援

若要確認 Windows 作業系統或 Linux 發佈以及相容 ESXi 主機的自訂支援,請參閱《VMware 相容性指南》,網址為:http://www.vmware.com/resources/compatibility。您可以使用此線上工具來搜尋客體作業系統和 ESXi 版本。在此工具產生清單之後,按一下客體作業系統,即可查看是否支援客體自訂。