主機上的 vSphere HA 代理程式已處於未初始化狀態一分鐘或更長時間。可能需要使用者介入才能解決這種情況。
問題
主機的代理程式無法進入執行狀態並成為主要主機時,或無法連線到主要主機時,vSphere HA 會報告代理程式處於未初始化狀態。因此,vSphere HA 無法監控該主機上的虛擬機器,並且在出現故障後可能不會重新啟動這些虛擬機器。
原因
vSphere HA 代理程式可能因一或多個原因而處於未初始化狀態。這種情況通常指示主機對任何資料存放區都沒有存取權。在少數情況下,指示主機對 vSphere HA 用來快取狀態資訊的本機資料存放區沒有存取權、主機上的代理程式無法存取,或 vSphere HA 代理程式無法開啟所需防火牆連接埠。也可能 ESXi 主機代理程式已停止。
解決方案
在主機的事件清單中搜尋近期發生的主機的 vSphere HA 代理程式出錯事件。此事件指明主機處於未初始化狀態的原因。如果由於資料存放區問題而出現這種情況,請解決任何阻止主機存取受影響資料存放區的問題。如果 ESXi 主機代理程式已停止,您必須將其重新啟動。解決上述問題後,如果代理程式未返回到操作狀態,請重新設定主機上的 vSphere HA。
備註: 如果由於防火牆問題而出現這種情況,請檢查主機上是否有其他服務在使用連接埠 8182。若是如此,請關閉此服務,然後重新設定 vSphere HA。