vRealize Automation 必要條件檢查程式的修正選項失敗,並顯示有關找不到 .NET 3.5.1 安裝來源的訊息。

問題

必要條件檢查程式需要確認已安裝 .NET 3.5.1,才能滿足 Windows Server 2008 R2 系統 (含 IIS 7.5) 與 Windows Server 2012 R2 系統 (含 IIS 8) 的需求。

對於 Windows Server 2012 R2,無法連線至網際網路會阻止自動安裝 .NET。某些 Windows 2012 R2 更新也可能會阻止安裝。發生此問題是因為 Windows 版本缺少 .NET Framework 3.5 安裝來源的本機複本。

結果

請手動提供 .NET Framework 3.5 安裝來源。

  1. 在 Windows 主機上,掛接 Windows Server 2012 R2 安裝媒體的 ISO。

  2. 在 Server Manager 中,使用「新增角色和功能精靈」來啟用 .NET Framework 3.5。

  3. 在執行精靈期間,導覽至 ISO 媒體上的 .NET Framework 3.5 安裝路徑。

  4. 新增 .NET Framework 3.5 之後,重新執行 vRealize Automation 必要條件檢查程式。