執行升級前,請先檢閱下列必要條件。

系統組態需求

確認已完成下列必要條件,然後再開始升級。

  • 確認屬於部署一部分的所有應用裝置和伺服器均滿足最新版本的系統需求。請參閱 VMware vRealize Automation 說明文件中的vRealize Automation 支援對照表〉

  • 請參閱 VMware 網站上的《VMware 產品互通性對照表》,瞭解與其他 VMware 產品之相容性的相關資訊。

  • 確認您要從中升級的 vRealize Automation 處於穩定的運作狀態。升級前更正所有問題。

硬體組態需求

確認已完成下列必要條件,然後再開始升級。

  • 執行升級之前,您必須至少擁有 18-GB RAM、4 個 CPU、Disk1 = 50 GB、Disk3 = 25 GB 以及 Disk4 = 50 GB。

    如果虛擬機器位於 vCloud Networking and Security,您可能需要配置更多 RAM 空間。

    儘管在 2016 年 9 月已結束對 vCloud Networking and Security 5.5.x (vCNS) 的一般支援,VCNS 自訂內容可繼續用於 NSX。請參閱 VMware 知識庫文章 End of Availability and End of General Support for VMware vCloud Networking and Security 5.5.x (針對 VMware vCloud Networking and Security 5.5.x 的可用性結束和一般支援結束) (2144733),網址為 http://kb.vmware.com/kb/2144733,以取得詳細資訊。

  • 主要 IaaS 網站、Microsoft SQL 資料庫和 Model Manager 節點必須具有以下資源:

    • Microsoft .NET Framework 4.5.2 版

    • 至少 5 GB 的可用磁碟空間

  • 以下節點必須已安裝 JAVA SE Runtime Environment 8 (64 位元) Update 111 或更新版本:

    • Model Manager Data 安裝所在的主要 IaaS 網站節點。

    • Microsoft SQL 資料庫節點。

    安裝 Java 後,您必須將環境變數 JAVA_HOME 設定為新版本。

  • 若要下載並執行升級,您必須具有以下資源:

    • 根磁碟分割上至少有 4.5 GB

    • 針對主要 vRealize Automation 應用裝置/storage/db 磁碟分割上有 4.5 GB

    • 針對每個複本虛擬應用裝置在根磁碟分割上有 4.5 GB

  • 檢查 /storage/log 子資料夾,並移除所有已封存的舊版 ZIP 檔案以清理空間。

一般必要條件

確認已完成下列必要條件,然後再開始升級。

  • 您具有受 vRealize Automation 升級影響或參與該升級之所有資料庫和所有負載平衡器的存取權。

  • 執行升級期間,使用者無法使用系統。

  • 您可以停用查詢 vRealize Automation 的任何應用程式。

  • 確認已在所有 vRealize Automation 以及相關聯的 SQL Server 上啟用 Microsoft Distributed Transaction Coordinator (MSDTC)。如需指示,請參閱 VMware 知識庫文章 Various tasks fail after upgrading or migrating to VMware vCloud Automation Center (vCAC) 6.1.x (2089503) (升級或移轉至 VMware vCloud Automation Center (vCAC) 6.1.x 後多個工作失敗 (2089503)),網址為 http://kb.vmware.com/kb/2089503

  • 如果您正在升級設定有內嵌式 PostgreSQL 資料庫的分散式環境,請完成以下步驟。

    1. 升級複本主機前,檢查主要主機上 pgdata 目錄中的檔案。

    2. 導覽至主要主機上的 PostgreSQL 資料夾,路徑為 /var/vmware/vpostgres/current/pgdata/

    3. 關閉 pgdata 目錄中任何開啟的檔案,並移除任何尾碼為 .swp 的檔案。

    4. 確認此目錄中的所有檔案都具有正確的擁有權:Postgres:users。