當您在 vRealize Automation 應用裝置 管理主控台的 [更新狀態] 頁面上按一下安裝更新時,會顯示有關管理代理程式的錯誤訊息。

問題

升級程序未成功。訊息顯示:無法在節點 x 上升級管理代理程式。有時該訊息會列出多個節點。

原因

許多狀況可能導致出現此問題。錯誤訊息僅指出受影響機器的節點識別碼。在 All.log 檔案中找到有關命令失敗的機器上管理代理程式的更多資訊。

根據您的情況,針對受影響的節點執行下列工作:

解決方案

  • 如果管理代理程式服務不在執行中,請啟動服務並在虛擬應用裝置上重新啟動升級。
  • 如果管理代理程式服務正在執行中,並且管理代理程式已升級,請在虛擬應用裝置上重新啟動升級。
  • 如果管理代理程式服務正在執行中,但管理代理程式未升級,請執行手動升級。
    1. 開啟瀏覽器並導覽至 vRealize Automation 應用裝置上的 [vRealize Automation IaaS 安裝] 頁面,網址為 https://va-hostname.domain.name:5480/install
    2. 下載並執行管理代理程式安裝程式。
    3. 將管理代理程式機器重新開機。
    4. 在虛擬應用裝置上重新啟動升級。